PS/2 to USB on Mac Mini problem

Discussion in 'Mac Basics and Help' started by NathanA, Mar 15, 2008.

  1. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #1
    Hey, everyone.

    I am the proud owner of a Mac Mini (MA723LL/A, 1.83GHz CD, SuperDrive) with a rather perplexing problem. I have searched the forums to see if anybody else has reported a similar problem but have come up empty; in fact, if anything, I found reports to the contrary indicating that what I'm doing should work just fine (and I don't see why it wouldn't).

    I am hooking up a normal PC PS/2 keyboard to the Mini using a PS/2 to USB adapter (the adapter has two input ports, one for a keyboard and one for a mouse...I'm leaving the mouse port empty and using a Bluetooth mouse). It works...some of the time. Frustratingly, most of the time, it doesn't immediately work in OS X after bootup. A good majority of the time, if I boot Mac OS, the keyboard is completely unresponsive. In order to get it to start working, I usually have to unplug the USB adapter from the back of the computer and then plug it back in. Sometimes it isn't even enough that I do it once...I have to do it twice, sometimes even three times before it recognizes that the keyboard is connected.

    I have the Mini currently triple-booting between Tiger, Leopard, and Windows XP; Tiger and Leopard are both patched up to the current maintenance release levels for their respective platforms (10.4.11 and 10.5.2). The keyboard problem happens under both Tiger AND Leopard, but interestingly enough Windows XP never has the problem!! Also, every once in a while instead of it not seeing the keyboard entirely until unplugging and replugging it in, it will just not start working until the second or third character I've typed, and then it magically comes alive (though when it is "dead" dead, it doesn't matter how many characters I type or how long I wait for it), and Windows XP never displays those particular symptoms either...there is no lag in Windows and I can start typing immediately after boot-up, nor does it ever fail to detect the keyboard.

    I tried getting a different PS/2 to USB adapter, and now have two (an unmarked/unbranded/generic version, and a Belkin product), and it happens when I use either one. I also tried a different keyboard just in case THAT happened to be the problem (was using a cheap Dell 'board which I tried replacing with an "IBM UK"-manufactured Model M board from '99), and I found that it happened with both 'boards as well.

    So it doesn't *appear* on the surface to be the adapter, nor does it appear to be the 'boards. And it only ever happens with Mac OS, never with Windows.

    Anybody have any idea? It's getting a "little" old having to get up and reach behind the computer to unplug and replug in the keyboard multiple times every time I boot back into Mac OS.

    Thanks a bunch,

    -- Nathan
     
  2. dops7107 macrumors 6502a

    dops7107

    Joined:
    Mar 19, 2005
    Location:
    Perth, Oztrailya
    #2
    I hate to say it, but bite the bullet and buy a USB keyboard. I went for the Apple USB one (previous to the current version) after trying a PS/2 one with an adapter. Never got it to work at all, in fact. Aren't PCs even moving away from PS/2 keyboards now? Flog it for $5 or something and buy another.
     
  3. NathanA thread starter macrumors 6502a

    Joined:
    Feb 9, 2008
    #3
    Yeahhhh, I suppose. But it SHOULD work, which is what pisses me off. It works with every other personal computer I've tried it on. I was actually just using the Dell as a stand-in until obtaining a Model M or something nicer...and the new Apple stuff really doesn't appeal to me.

    I know others who use Model Ms with their Minis...I've read their posts on here and other forums. Do they have the same problem, and do they just silently put up with it?

    Actually, I'd be willing to give up the PS/2 to USB paired with an IBM Model M if I could find an old ADB Apple Extended Keyboard (I or II) in really good shape, and then just hook it up using an iMate or something. I've been checking around eBay for a little while and most of them look like they're in crap condition, so I'm beginning to despair of being able to find something.

    -- Nathan
     

Share This Page