PS CS4: "Not enough ram" (WTF)

Discussion in 'Design and Graphics' started by MBX, Jun 15, 2009.

  1. MBX macrumors 68000

    Sep 14, 2006
    I'm trying to open a print still image at size of around 6600x6600 and it's like 22mb and photoshop CS4 is telling me it can't open it because "not enough ram".

    Running unibody 17'', 8GB Ram.

    WTF? The file is only 22mb. I've been opening far bigger psd files (some were around 500mb).

    Opening the 22mb tiff file in preview was absolutely no problem. And when i resized the image to 50% of it's scale for test-purposes i could open it in photoshop.

    Any idea why PS is acting this way?
  2. samwich macrumors regular

    Aug 5, 2007
    Photoshop CS4 for the mac is not 64 bit so it can only take advantage of up to 3.3 gb of ram at most (often a little less than that).

    Second the size of the psd document does not directly correlate to how much memory it will take up when the document is actually open.
  3. NathanCH macrumors 65816


    Oct 5, 2007
    Stockholm, Sweden
    I don't think the fact that it's not 64 bit is the issue primarily because I've opened files much larger in length without problems - even on a system with only 2GB of ram.
  4. Genghis Khan macrumors 65816

    Genghis Khan

    Jun 3, 2007
    Melbourne, Australia
    well unless, anybody has opened images larger than this on a probably really don't have enough RAM...simple (and unfortunate) as that...
  5. iBookG4user macrumors 604


    Jun 27, 2006
    Seattle, WA
    Have you tried to open the file after a restart? That can usually solve some anomalies such as this one.
  6. chaosbunny macrumors 68000


    Mar 11, 2005
    down to earth, far away from any clouds
    This... or maybe even restarting Photoshop is enough. I just opened a 8376x7776 px 320 mb file just fine on my 4gb ram iMac, and that's with Illustrator, InDesign and other usual suspects opened too.

    I had a similar problem with Illustrator 2-3 times, it couldn't open something and said not enough ram, I just restarted the programm and it worked.
  7. Consultant macrumors G5


    Jun 27, 2007
    Probably incorrect RAM setting. Reset to default settings.

    Or contact Adobe?
  8. tbrinkma macrumors 68000

    Apr 24, 2006
    Just a note. Just because the file itself only weighs in at 22MB, doesn't mean doesn't take significantly more memory when PhotoShop converts it to it's native memory structure. Assuming 8 bits per channel, you're looking at roughly 43MB just for the raw image data, and PhotoShop has a good bit of overhead in it's in-memory data structures. At 6600x6600, you've got a fairly large image there. How much RAM did you have free when you tried to open it?
  9. daver11 macrumors regular

    Feb 11, 2005
    Phoenix, AZ
    6600 x 6600 corresponds to a image size of 166.2mb (see screen capture). 8gb of RAM should be more than enough.

    Try creating a new file at this size and see how it works. Perhaps there is some problem with the PS file itself...

  10. IgnatiusTheKing macrumors 68040


    Nov 17, 2007
    das Fort
    I work on files in the hundreds of MB regularly on a Mac Pro with 6GB RAM. Something is goofy here, and it's not the amount of memory the OP has.
  11. electrolux76 macrumors member

    Oct 30, 2008
    There is probably some data corruption in the file that is giving PS a problem but not Preview. The easiest thing to try, if it is a flat file (no layers) is to open it in preview and then resave it as a .tiff. Make sure to save as tiff, not jpeg so there won't be quality loss. Try to open your new tiff in PS and see if it works. You can do this even if you do have layers in your file but the layers will be flattened.
    If this doesn't do it the other thing you could try are(listed in order of pain in the assness):
    •Double check that your OS and Photoshop have all their latest updates
    •Change the memory allocation settings in photoshop's prefs. I believe its under its under the "performance tab" but I'm not on my machine w/CS4 right now.
    • Turning off OpenGL accelaration
    • Deleteing PS's prefs file. (homefolder>library>preferences>Adobe Photoshop CS3 Settings>Adobe Photoshop CS3 Prefs.psp
    • Reinstalling PS
  12. MBX thread starter macrumors 68000

    Sep 14, 2006
    No idea what's going on. I restarted many times, still same problem.

    As said resizing the file down to 50% works but it's not ideal.

    The ram setting is set to 100% and because PS isn't making use of the 8GB it can only go max 3072MB.

    I'll try some of the suggestions (settings and turning off OpenGL) soon though.

  13. whooleytoo macrumors 604


    Aug 2, 2002
    Cork, Ireland.
    Could you be running low on disk space? With VM, the more RAM you have the more disk space is required for VM too; along with what Photoshop uses as a scratch disk too.
  14. Snowy_River macrumors 68030


    Jul 17, 2002
    Corvallis, OR
    The fact that scaling the image fixes the problem, to me, suggests that the original image is corrupt. You might try scaling the image UP instead of down and see if this works.

    It is odd, though, that PS doesn't like it but Preview does. In my experience, PS will read corrupted files more often than Preview.
  15. calliope8muse macrumors newbie


    Dec 29, 2009
    London, UK
    any updates on the photoshop 32bit, 3072 RAM issue please?

    Ok this is an old post and this is 2010 now are there any updates on the issue on either side Adobe or Mac in order to have this fixed?:apple:

    Because it is a pity to spend some considerable grant buying that 8Gb ram on Mac OS only to find out that you can't use it, do you know?!:eek:
  16. opeter macrumors 68000


    Aug 5, 2007
    Slovenia, EU
    Yeah, thats why I am using Photoshop on Windows 7.
  17. snberk103 macrumors 603

    Oct 22, 2007
    An Island in the Salish Sea
    There is a good site, Mac Performance Guide that does a good job of explaining how a Mac and PS use memory.

    I'm just going from memory here (no pun intended, well - Ok it was intended) but.... While PS is limited to less than 4 GB of memory, the OS isn't and it uses VM and scratch disks rather well to manage memory. If the OP is having problems with a 22 MB file (I know this is an old problem) then there is something wrong with the installation, the file, or there isn't enough room for VM (i.e. the HD is nearly full).

    I've managed to edit a 1GB PS file on a Mac Mini with only 2GB of memory - it ain't pretty, but it can be done. See the performance guide above - it is very good info.
  18. THX1139 macrumors 68000


    Mar 4, 2006
    Not until the software goes 64bit and your machine supports it. And by the way, you can use 8GB of ram. Just not all on the same application. This is one particular area that Apple is waaaaay behind on. On the Windows side, you can get a generic home user computer that operates at full 64bit. My grandmas computer has the ability to access more ram than my Macpro that I use for business.

Share This Page