PS CS5 extremely slow on OS X.

Discussion in 'Mac Apps and Mac App Store' started by ZebraineZ, Jul 9, 2010.

  1. ZebraineZ macrumors 6502

    Joined:
    Mar 17, 2009
    #1
    Hey, I don't really know what is wrong, it's a fresh installation and it's just extremely laggy, liquify is slow as heck, drawing and doing anything is just choppy or buggy. Heck, my MB is more than decent for PS, so I don't know what is going on!

    CS4 ran fine with no lag, and CS3 on my old p4 with 512mb ram runs smooth as silk with no lag, even when I use liquify, and even then it's only allowed to use 170mb of it.

    I know this is a well known problem and I am not the only one, but I just wanted to know what exactly is the problem if anybody has managed to fix it, and a lot of the menu's and window structures are a bit off/messed up as well, it seems to me that a lot of unneeded yet subtle changes were made, and it's annoying as well...

    If you read this just reply back :p I don't want this thread to die lol, just say something!
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #2
    Did you update it?

    What machine are you running this on?
     
  3. brandon.8602 macrumors member

    Joined:
    Jul 3, 2010
    #3
    I would recommend rebooting your machine and giving it a minute or two to complete the startup processes, then try running PS again. I will admit it is slow but it isn't slow enough (at least in my case) to hinder my work. If your problem persists, if reinstalling is an option then try that. If you still have issues, you might want to consider upgrading to 1 gb of ram or more if you have the personal funds
     
  4. ZebraineZ thread starter macrumors 6502

    Joined:
    Mar 17, 2009
    #4
    Did any of you manage to actually READ the thread, all of it? My computer specs are clearly written in my signature, there is no excuse for CS5 to be acting this way if CS4 worked perfectly fine on the same macbook before I had CS5.

    Even CS3 working without lag on the same tasks on a different old computer with only 170mb of ram, the SAME tasks that CS5 lags horribly on my macbook.
     
  5. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #5
    hey man, dont hate. they are just trying to help you out.

    CS5 has a lot of new technologies, and nah it shouldnt be slowing down - but unfortunately it is. check your FS and let us know what it is (HFS journaled? etc), make sure you have enough free RAM (how many page outs/swap size do you have), reboot the computer, try on another user account, check CPU usage and make sure you dont have anything chewing through CPU usage - and report back and let us know.
     
  6. GoKyu macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #6
    Photoshop really wants more RAM to run decently, especially the latest version. 2 gigs is a bit low - remember that Photoshop tries to use about half your available memory by default, and I don't think a gig's gonna cut it on CS5.
     
  7. deadwulfe macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #7
    +1,000

    I don't get why people WITH the problem, that are inclined to post on an open forum for feedback, are so quick to bark at people who try to help. You can get more with a teaspoon of honey than a pound of spice.

    Anyways, I don't have anything to add to this thread, since DoFoT9 has covered more than I could think of.
     
  8. Xavier macrumors 68020

    Joined:
    Mar 23, 2006
    Location:
    Columbus
    #8
    I've got 4gb ram on my laptop. Upgraded to CS5 and everything is running very smooth and fast.

    MBP 2.4ghz with 4gb
     
  9. Bruce.Lee macrumors newbie

    Bruce.Lee

    Joined:
    Jun 30, 2010
  10. AlexMoore macrumors newbie

    Joined:
    Jul 20, 2010
    #10
    I've got the last model 24" iMac with 4gig RAM and was also finding photoshop CS5 to be laggy as anything (got the Nvidia 9400).

    After a bit of digging turning a few options off / down seems to have sorted it.

    Under: Preferences / performance
    - set the openGL advanced setting to "basic"

    And under: Preferences / general
    - Untick: - "enable flick planning"

    I've also unticked "animated zoom" but I think it's the panning one that really makes it feel laggy as hell.

    Hope that helps.
     

Share This Page