PS3 and Airport Extreme

Discussion in 'Console Games' started by Kurrosh, Mar 10, 2010.

  1. Kurrosh macrumors member

    Joined:
    May 29, 2008
    #1
    Hey

    I recently bought a PS3 slim and was hoping to connect it wirelessly to the internet, but it appears that it can't connect to Airport Extreme. It's very strange because when I click 'Scan' for the networks, it finds two networks, each called 'Extreme' (Extreme is the name of my wireless) with one at 100% the other at 95% or sometimes both at 100%. Anyways, I have tried both and neither worked. So after choosing one, I enter my WPA/WPA2 password and then click next, saying 'automatic' for my IP address etc.

    Now the problem is, once this is all done I choose 'Test Connection' and it says 'Connecting to access point...' then 'Exchanging key information' which is where it fails. It stops there and I get an error message: "The key information exchange timed out. The WPA key you entered may not be correct." I know for a FACT that the password I entered was correct; I have tested it multiple times and on multiple machines which (I used it on my laptop, and it worked for example). Now another really strange thing is that if I am lucky, sometimes (not too often), after 10-15 minutes of not doing anything, all of a sudden I realise that somehow the PS3 managed to connect on it's own. S

    The PS3 connected no problem to my friends wireless (he uses a SpeedTouch).

    Cheers for any help.
     
  2. StruckANerve macrumors 6502

    Joined:
    Dec 31, 2008
    Location:
    Rio Rancho, NM
    #2
    The PS3 does not support 802.11n signals. Make sure that you are broadcasting a B or G signal with the AE and then connect to that.
     
  3. Kurrosh thread starter macrumors member

    Joined:
    May 29, 2008
    #3
    Ahhhhhh, can't believe I didn't think of that. Thanks :)
     

Share This Page