• Did you order new AirTags? We've opened a dedicated AirTags forum.

Ryan Stewart

macrumors newbie
Original poster
May 31, 2010
4
0
Hello!
Basically i'm needing to know how to connect my PS3 controller to my new Mac mini running Lion. I have seen countless tutorials for Snow Leopard that tell you to plug it in via USB, press the PS button, unplug it then press it again and it pairs. When I do this on Lion however I get a popup asking for a passcode to continue. I have tried 0000 and countless others but to no avail. I have also tried pairing it back with my PS3, then back with the Mac but get the same issue.

Has anyone got this working, and can you tell me how?
 

Ryan Stewart

macrumors newbie
Original poster
May 31, 2010
4
0
I have this install dyes, although I think it's only if you use it while plugged into USB. The controller works fine with USB and Gamepad Companion, but I would really like the Bluetooth to work instead. The plan is to copy my Team Fortress 2 PS3 config onto my Mac copy for it to work.

It's just this passcode thing that is stopping me from doing that...
 
Comment

drxcm

macrumors regular
Nov 2, 2010
217
52
I have this install dyes, although I think it's only if you use it while plugged into USB. The controller works fine with USB and Gamepad Companion, but I would really like the Bluetooth to work instead. The plan is to copy my Team Fortress 2 PS3 config onto my Mac copy for it to work.

It's just this passcode thing that is stopping me from doing that...

This is really bugging me.

It pairs with my MBP 17" running Lion, no passkey required.
But with my MBA, it is asking for a passkey constantly. Can't pair it.

Anyone have any suggestions? I tried deleting my bluetooth prefs, resetting the controller etc.
 
Comment

Pandakopanda

macrumors newbie
Sep 15, 2008
12
6
Same problem here.

I had a Mac mini 2010 with SL and the PS3 controller worked. I upgraded the Mac mini 2010 to Lion and the PS3 controller still worked. But now I have a new Mac mini 2011 and I get the passcode dialog when pairing.

Since it worked in Lion on an older Mac mini, I guess it's a hardware/driver issue. Really annoying since I have to find another solution to connect a gamepad. I know some wired USB gamepads work but I rather have a wireless solution.

Maybe it worked on the Mac mini 2010 because it was a Lion upgrade and not a clean install. But then people who did do a clean install should have the same issue.
 
Comment

ZZ Bottom

macrumors 6502a
Apr 14, 2010
807
206
I know its been a while since you last posted, but I think I might have a clue.

All the systems you mentioned that aren't working contain the newer bluetooth chip that is compatible with bluetooth 4.0. Obviously there is something different with this chip that is causing the problem. Perhaps asking the right people based on that theory might help you find a solution.
 
Comment

northy124

macrumors 68020
Nov 18, 2007
2,293
7
Has anyone got a PS3 controller to work with the 2011 MBP (I bought mine in August, not sure of model)? just want to know before I buy a new PS3 controller to use with the MBP (other one is a Six axis and crap).
 
Comment

Queen6

macrumors G3
Has anyone got a PS3 controller to work with the 2011 MBP (I bought mine in August, not sure of model)? just want to know before I buy a new PS3 controller to use with the MBP (other one is a Six axis and crap).

Yes mine works over Bluetooth, just tried Batman Arkham Asylum perfect, Late 2011 MacBook Pro 15" 2.4 Core i7 & Sony DualShock3 Six Axis.

Heres the "kicker" 3 controllers (other 2 are from the original PS3) will work, however the controllers will not pair, yet they work; Batman Arkham Asylum 100% NOVA 2, only within the game, no menu control etc, COD4 Modern Warfare seems to ignore the PS3 controller with or without USB
 
Last edited:
Comment

jonahjones26

macrumors newbie
Dec 5, 2011
2
0
Warwickshire
just joined the forum to find this answer as its bugging me now, i am always asked for a code when pairing the controller..........also i cannot get it to work connected to usb either. This maybe becasue i have an old macbook 2008 on lion so the bluetooth device may differ?

can anyone reccommend a good alternative controller if this will not work?
 
Comment

souloxide

macrumors newbie
Dec 8, 2011
3
0
this is driving me nuts! I too am getting that pairing code request!! no luck with USB either.. please help!! :(

strangely enough, with the USB connected, deathspank was able to identify the controller connected but I couldn't configure/assign the keys correctly..

I have mid-2011 iMac i7 originally with SL and then I upgraded to Lion.. I had a wireless xbox 360 controller that stopped working in Lion so I traded it with the dualshock PS3 controller at gamestop.. unfortunately, I'm now facing the same problem as you guys.. bummer!
 
Comment

souloxide

macrumors newbie
Dec 8, 2011
3
0
tried the 0000 passcode.. it connects for a while and then disconnects itself bringing back the pairing request code window..

was able to make it work via USB though.. I would've loved to use the controller wirelessly but i guess this will do for now..
 
Comment

S3R6i0

macrumors regular
Dec 17, 2011
126
61
Yellow!

Don't worry about bluetooth. Lion has wired native support. Plug in your PS3 controller and leave it plugged in. I'm playing GTA III from the App Store right now.
 
Comment

dkirky

macrumors newbie
Dec 21, 2011
1
0
Lego sw3

Has anyone gotten a PS3 controller to work with LEGO Star Wars3 in Lion?
I keep getting asked for pairing code. Have emailed Feral and they keep referring me to the SnowLeopard fix. Doesn't work with Lion.
 
Comment

Smileyboy

macrumors 65816
Aug 6, 2008
1,135
124
Don't worry about bluetooth. Lion has wired native support. Plug in your PS3 controller and leave it plugged in. I'm playing GTA III from the App Store right now.

So all indeed to do is just plug it in? I'm trying Jedi knights 2 on my MBA 2011 and it's not working.
 
Comment

NewMacUser2012

macrumors newbie
Jan 1, 2012
7
0
Also frustrated

just bought a ps3 controller so i could wirelessly play some platformers like LIMBO on my late 2011 27" iMac and i'm having the same problem. I do what everyone says should work: plug the controller in via USB, press the playstation center button, unplug, press the button again... and i'm prompted for a passcode. I try 0000 and it connects briefly but DOES NOT PAIR! after a few seconds it drops the connection.

wtf! nothing on this POS mac works like it's supposed to. if i still had the box i'd return it.
 
Last edited:
Comment

labrille12

macrumors newbie
Feb 11, 2012
2
0
Solution !!!!!!

just bought a ps3 controller so i could wirelessly play some platformers like LIMBO on my late 2011 27" iMac and i'm having the same problem. I do what everyone says should work: plug the controller in via USB, press the playstation center button, unplug, press the button again... and i'm prompted for a passcode. I try 0000 and it connects briefly but DOES NOT PAIR! after a few seconds it drops the connection.

wtf! nothing on this POS mac works like it's supposed to. if i still had the box i'd return it.

Hello, i am French. Sorry for my english.
I have find ! Their is no passcode. If you have apairing code, that's you have do a mistake in your way of connect ps3 controller.
To pair PS3 controller (on Lion) :
- enable Blutooth
- Plug controller in via USB
- Press PS button 3 times (quickly - find the good speed - This is the key of the problem) (and not 2 seconds 3 times than i have see in lots of forum)
- unplug USB on mac and on the controller​
Now their is no passcode, and your ps3 controller is pairing in bluetooth
ENJOY :)
 
Last edited:
Comment

NewMacUser2012

macrumors newbie
Jan 1, 2012
7
0
To pair PS3 controller (on Lion) :
- enable Blutooth
- Plug controller in via USB
- Press PS button 3 times (quickly - find the good speed - This is the key of the problem) (and not 2 seconds 3 times than i have see in lots of forum)
- unplug USB on mac and on the controller​
Now their is no passcode, and your ps3 controller is pairing in bluetooth
ENJOY :)

That did not work either.
 
Comment

aruseman

macrumors newbie
Feb 11, 2012
3
0
Hi,

I just figured out how to use the PS3 controller in Lion, via bluetooth, no need for any drivers.

It has not to be paired, just *configured* and *added to favorites* devices under bluetooth pref pane.

In order to do that,

1) plug the pad using the usb cable, unplug it.
2) don't care about the pairing request
3)Open Bluetooth Preferences (you have ~15 sec)
4)select the ("connected" and "configured" but not "paired") "Playstation3 controller"
5)add it to favorites

6) disconnect the controller from Bluetooth menu bar


7) push the PSX button on the controller, it will connect and you are ready to play.



Tested on 10.7.2 1nd 10.7.3 on MacBookAir 2011 and MacMini Server 2011
 
Comment

NewMacUser2012

macrumors newbie
Jan 1, 2012
7
0
Hi,

I just figured out how to use the PS3 controller in Lion, via bluetooth, no need for any drivers.

It has not to be paired, just *configured* and *added to favorites* devices under bluetooth pref pane.

In order to do that,

1) plug the pad using the usb cable, unplug it.
2) don't care about the pairing request
3)Open Bluetooth Preferences (you have ~15 sec)
4)select the ("connected" and "configured" but not "paired") "Playstation3 controller"
5)add it to favorites

6) disconnect the controller from Bluetooth menu bar


7) push the PSX button on the controller, it will connect and you are ready to play.



Tested on 10.7.2 1nd 10.7.3 on MacBookAir 2011 and MacMini Server 2011


That didn't work either. Just like before, it drops the connection after 10-20 seconds. regardless of my process, the controller will not pair and it will not work.
 
Comment

takhrai

macrumors newbie
Feb 12, 2012
1
0
Hi,

I just figured out how to use the PS3 controller in Lion, via bluetooth, no need for any drivers.

It has not to be paired, just *configured* and *added to favorites* devices under bluetooth pref pane.

In order to do that,

1) plug the pad using the usb cable, unplug it.
2) don't care about the pairing request
3)Open Bluetooth Preferences (you have ~15 sec)
4)select the ("connected" and "configured" but not "paired") "Playstation3 controller"
5)add it to favorites

6) disconnect the controller from Bluetooth menu bar


7) push the PSX button on the controller, it will connect and you are ready to play.



Tested on 10.7.2 1nd 10.7.3 on MacBookAir 2011 and MacMini Server 2011

Can you please take some screenshots? I can't find "Select the connected and configured but not paired" and "add it to favorites"
 
Comment

PirateMonkey

macrumors member
Oct 12, 2011
40
1
Hello!
Basically i'm needing to know how to connect my PS3 controller to my new Mac mini running Lion. I have seen countless tutorials for Snow Leopard that tell you to plug it in via USB, press the PS button, unplug it then press it again and it pairs. When I do this on Lion however I get a popup asking for a passcode to continue. I have tried 0000 and countless others but to no avail. I have also tried pairing it back with my PS3, then back with the Mac but get the same issue.

Has anyone got this working, and can you tell me how?

Hi there I had the same problem as you until just now I hopefully have figured it out, like said before add to your favourites but once you have done that in the same drop down box click update services, after I done this (touch wood) it's not asked me for any password and has kept the settings.
 
Comment

mark427

macrumors newbie
Feb 14, 2012
1
0
Working for me

I had same problem on MBP 2011 in Lion where it pairs, then drops connections shortly after, but got it to work finally heres what I did:

1. Open bluetooth from system preferences.
2. Get your PS3 controller to ask for pairing passcode (pressing PSX button). 3. Then enter new passcode (I used letters only "xxxx" don't know if it matters)
4. Now you should see PS3 Controller "Connected" in that list of Bluetooth devices. Select it and click the little gear in the bottom left corner and select add to favorites and then update services.
5. THIS IS THE STEP THAT FINALLY MADE IT REMEMBER. Turn off Bluetooth right away before it asks to pair all over again. The lights on the controller should stop flashing. Turn Bluetooth back on.
6. Press PSX button once and should pair in bluetooth right away. The lights will start flashing again and stay flashing all the time. They turn off when you disconnect it from bluetooth or turn bluetooth off.

Post if this works or not. MPB Early 2011 with OS Lion 10.7.3

Edit: I got the controller to be connected and lights off. After step 5, plug controller in USB, the lights should be flashing (slower though). Press the PSX button once, unplug USB, controller will pair in few seconds and lights will turn off.
 
Last edited:
Comment

nickfer3

macrumors newbie
Feb 15, 2012
1
0
Worked for me too

I followed all your steps and it FINALLY worked for me too!! Mine is a MacBook Pro Late 2011 with OS Lion 10.7.3 . I possibly have bluetooth 4.0 also, since none of the other methods I tried worked...

For all you guys who couldn't get it to work, and already tried installing 3rd party software (like iPS3), drivers, and none of them worked... THIS IS THE WAY TO GO!! :D

Thanks mark427 !!!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.