PS3 controller on OSX EL Captain

Discussion in 'OS X El Capitan (10.11)' started by Williams91, Nov 5, 2015.

  1. Williams91 macrumors newbie

    Joined:
    Nov 5, 2015
    #1
    Hi

    For the past few days I have been having s devil of a time trying to hook up my ps3controller to my MacBook Pro. I have gone through multiple guides and instructions online and on forums how to go about setting this up yet still no luck.

    What I have noticed us I have charged the controller then reset the controller, hooked it up to the Mac via usb the Mac does not recognize anything but the controller first start to flash. Now when I turn Bluetooth on the Mac and hit the ps button on the front of the controller connected or disconnected nothing happens. The controller does not even show up detected in the Bluetooth menu. I have tried turning in/off plugging in/unplugging and nothing. The controller does not even get recognized when hooked up via usb does the Mac need drivers downloaded to it?


    Can somebody please help or if had the same issue please guide me as I am at the end of my tether with this thing.

    Thanks in advance.
     
  2. Williams91 thread starter macrumors newbie

    Joined:
    Nov 5, 2015
    #2
    I might also add I tired a GameCube use controller before this via use and the MacBook did not detect it. Am I missing something guys?
     
  3. pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #3
    you need six pair axis...maybe.
     
  4. PlutoX, Nov 7, 2015
    Last edited: Nov 7, 2015

    PlutoX macrumors newbie

    PlutoX

    Joined:
    Nov 7, 2015
    #4
    I have exactly the same problem. Have you found any solution yet?

    Connecting my PS3 Gamepads worked before... until i updated to 10.11.2
     
  5. Queen6, Nov 7, 2015
    Last edited: Nov 7, 2015

    Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #5
    Last time I used a PS3 controller, it worked fine on 10.10.5 I just connected the controller via USB opened a game, checked the controller was working and pulled the cable more USB cable required.

    Just checked on a recent clean install of 10.10.5 PS3 Controller works no issue, shows up in the BT menu, however not in BT preferences

    Q-6
     
  6. PlutoX macrumors newbie

    PlutoX

    Joined:
    Nov 7, 2015
    #6
    Ok, i solved 'my' problem..

    Since my usb ports could easily read memory sticks or my iPhone, they could NOT detect my PS3 gamepads. Which is strange because it obviously used to work before.. thanks for pointing that out, Queen6.

    BUT since i updated to the super developer alpha turbo edition 10.11.2, **** hit the fan. I got kind of frustrated from those many tutorials how to "repair" it manually.. because i kind of suck at this.

    So i just re-downloaed El Capitan 10.11.1 from the App Store, installed it, and BÄM! My PS3 Controllers work again.
     
  7. rem2608, Jan 27, 2016
    Last edited: Jan 28, 2016

    rem2608 macrumors newbie

    rem2608

    Joined:
    Jan 27, 2016
    #7
    I found a way

    1) the gamepad must be turned off (no blinking lights)

    2) the bluetooth is off

    3) open bluetooth preferences pane

    4) connect the gamepad with usb cable to mac

    5) press and hold for 5/10 sec. the PS button

    6) release the PS button and disconnect the USB cable

    7) from now the gamepad is connected, check the drop down menu for Playstation(R)3 controller (the first time you connect the gamepad the blinking lights are off, but the gamepad is on, i don't konw why)

    P.s. I have Mac osX 10.11.3
     

Share This Page