MP 7,1 PSA: Radeon RX 5700 XT works fine under 10.15.2

penguinlust

macrumors newbie
Original poster
Dec 19, 2019
12
8
Installed a Sapphire Pulse 5700 XT in my 7,1 and it worked from the get go once I updated to 10.15.2. Even better, I removed the 580X MPX module and put it in that space so as not to waste a slot.

(I needed to hook up an old Apple 30'' -- easy to get it to convert to DP (or mini DP), but I can see no reasonable way to get it to HDMI or Thunderbolt 3)
 

Passingby

Suspended
Dec 17, 2019
117
161
If any of the ports are not working on off-the-shelf cards go to AMD's website and download the latest drivers.

Oh wait...we can't do things like that 😂
 

bsbeamer

macrumors 68040
Sep 19, 2012
3,453
1,757
RX 5700 XT 8GB works in 10.15.1+ since there are drivers, but performance with those drivers is just not very good. Waiting for 10.15.3+ for Apple to address. Hopefully before/when W5700X is available.
 

bsbeamer

macrumors 68040
Sep 19, 2012
3,453
1,757
That's interesting. What stock config did your MP7,1 ship with? Do you know what the build number of the shipping version of 10.15.1 was?

MP7,1 is not officially publicly supported with any OS version prior to 10.15.2, so I wonder if you were "given" a beta or special build of 10.15.1 accidentally, or if it was built/shipped with an early version with the explicit intention of being updated upon delivery.
 

penguinlust

macrumors newbie
Original poster
Dec 19, 2019
12
8
That's interesting. What stock config did your MP7,1 ship with? Do you know what the build number of the shipping version of 10.15.1 was?

MP7,1 is not officially publicly supported with any OS version prior to 10.15.2, so I wonder if you were "given" a beta or special build of 10.15.1 accidentally, or if it was built/shipped with an early version with the explicit intention of being updated upon delivery.
Sadly I did not note the build number before I updated it, and yes, the first thing I got upon my first full boot was the software update panel. I did an "About This Mac" on initial boot and verified it was 10.15.1 (which surprised me as well), but my main goal was to verify it had the hardware in it I had paid for.

As to the machine, 16 cores with 48 GB RAM and a 1 TB SSD and the 580X (which I knew I wasn't going to use). It's for software development primarily. Will be adding more RAM soon.

I wonder if there's a market for unused 580X MPX modules?
 
Last edited:
  • Like
Reactions: bsbeamer

kjohansen

macrumors member
Nov 19, 2008
97
46
Oregon
That's interesting. What stock config did your MP7,1 ship with? Do you know what the build number of the shipping version of 10.15.1 was?

MP7,1 is not officially publicly supported with any OS version prior to 10.15.2, so I wonder if you were "given" a beta or special build of 10.15.1 accidentally, or if it was built/shipped with an early version with the explicit intention of being updated upon delivery.

Mine shipped with 10.15.1 also, it is now running 10.15.2
 

bsbeamer

macrumors 68040
Sep 19, 2012
3,453
1,757
RX 5700 XT 8GB works in 10.15.1+ since there are drivers, but performance with those drivers is just not very good. Waiting for 10.15.3+ for Apple to address. Hopefully before/when W5700X is available.
Some may find this helpful or useful, my report and possible temporary "fix" for performance issues with RX 5700 XT:
 

arock

macrumors member
Apr 29, 2005
51
30
Some may find this helpful or useful, my report and possible temporary "fix" for performance issues with RX 5700 XT:
That is quite interesting! I wonder if the same effect occurs installed inside the new MP and/or with the Radeon VII. I'll be able to test it in a couple days when my new 7,1 arrives.
 

bsbeamer

macrumors 68040
Sep 19, 2012
3,453
1,757
That is quite interesting! I wonder if the same effect occurs installed inside the new MP and/or with the Radeon VII. I'll be able to test it in a couple days when my new 7,1 arrives.
The DP & HDMI 4K/UHD headless adapters should be here in few days, will try to test with them soon.
 

Synchro3

macrumors 68000
Jan 12, 2014
1,975
829
So we have the confirmation that the new Mac Pro 7,1 supports boot screen including option boot with a normal PC graphics card.

This is an important information regarding future graphic cards.
 

Passingby

Suspended
Dec 17, 2019
117
161
Now you can stop calling them PC graphics card and just call them graphics card 😅

Nvidia and forthcoming Intel GPUs must also be supported and Mac users should be able to download graphics driver online on the same day/week that Windows users always get new drivers.
 

bsbeamer

macrumors 68040
Sep 19, 2012
3,453
1,757
GB 5.1 METAL scores 70,000+ with eGPU in MBP16,1 with RX 5700 XT, but issues with DP port 3. Rest of scores all over the place depending on monitor config. Really believe there’s a driver issue.

 

flowrider

macrumors 603
Nov 23, 2012
5,694
2,039
Put my Aorus RX 5700 XT in yesterday. Pulled the Pro 580X. Running fine for me. Boot Screens - A little strange, but I got it. On a cold boot, I get a stretched Apple and a long progress bar. On a Restart, the screen shows with the proper resolution. Also, the boot screen acts like a flashed card does in a 5,1 cMP. Near the end of the UEFI, transitioning to the desktop it will go to black screen then to the tail end of progress bar then to desktop.

Ran a couple of benchmarks:

Heaven 10.15.3 RX580XT.png
Metal RX7500XT.png


Lou
 

bsbeamer

macrumors 68040
Sep 19, 2012
3,453
1,757
What port(s) were you using for the METAL benchmarks, if any?

I've noticed a distinct improvement and benchmark difference with DP1, DP2, and HDMI all connected in some fashion vs. HDMI only or NONE when testing with eGPU in Catalina. Headless adapters are an easy/cheap way to work around this if you do not have access to monitors.

Using DP3 (port number 3) in any capacity on RX 5700 XT results in system freezes or automatic restarts. DP3 is the last/bottom port, furthest away from the bracket portion of the "L" on the card (closest to the PCIe pins). Port order for reference is DP1, DP2, HDMI, DP3. BIOS switch position makes no difference.
 
  • Like
Reactions: erroneous

flowrider

macrumors 603
Nov 23, 2012
5,694
2,039
^^^^

Port Selection.jpg


The Aorus card has more ports than other RX 5700 XT. 3 DP and 3 HDMI.

Lou
 
Last edited:

bsbeamer

macrumors 68040
Sep 19, 2012
3,453
1,757
Can't help but wonder what the "scores" would be if all six port were connected to something. Also curious if all ports actually work with macOS, or if there is a similar situation where one (or more) simply do not function correctly with macOS.

Unfortunately, the Aorus 5700 XT is too wide for nearly all eGPU setups. Likely only for MP7,1 for Mac usage unless someone is tricking out an MP5,1 and does not care about slot 2 at all. Personally wish some standard 16GB+ models would start surfacing.
 

UmarOMC

macrumors member
Apr 16, 2010
41
10
NYC
Hmmmmm 🤔 Now I'm wondering if the port I'm using with my Radeon VII is what's giving me sporadic problems—WindowServer choking to death sometimes, com.apple.DumpGPURestart events sometimes dumped throughout my system.log, especially during rounds of Dying light…
 

zhpenn

macrumors regular
Aug 27, 2014
179
73
Tried my VII, god 62138 on Metal, btw is the nav base 5700 will have a lot better H264 export speed?


VII Metal.png


and 580x Metal
580x Metal.png

- - Post merged: - -