PSE8 not compatible with G5 PPC Macs?

Discussion in 'Design and Graphics' started by AlaskaMoose, Nov 10, 2009.

  1. AlaskaMoose macrumors 65816

    Joined:
    Apr 26, 2008
    Location:
    Alaska
    #1
    It seems to be that way:mad:

    I ordered PSE8 at school (very nice educational discount), and received it today. That's when I read the side of the package and realized that the system requirements are for:

    - Multi-core Intel Processors
    -Mac OS X 10.4 through 10.6

    My G5 iMac has a PPC processor, although is running under Mac OS 10.5.8. I may have to install it on my son's Intel iMac instead, or maybe I just buy a new 21-inch screen iMac :)
    --------
     
  2. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #2
    This is true. Always check or research system requirements before buying software, especially for Macs that are a few years old. If the pack is still unopened, then see if you can get a refund. If not, then see if you can recover the costs on eBay, Craigslist, or even selling it to a fellow student.

    Or yes, buy a new Mac. After all, you deserve it. ;)
     
  3. mofunk macrumors 68000

    mofunk

    Joined:
    Aug 26, 2009
    Location:
    Americas
    #3
    lol didn't you hear? PPC is old. I noticed that too. I can't upgrade my software cause the main two Adobe and Apple isn't compatible. I played with the new iMacs at the Apple store. They are sweet.
     

Share This Page