PSO2 On Mac?

Discussion in 'Mac and PC Games' started by MacUserMichael, Jul 6, 2012.

  1. MacUserMichael macrumors newbie

    MacUserMichael

    Joined:
    Jun 21, 2012
    #1
    I really want to play this game.

    How can i play it on a mac?
     
  2. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #2
    Windows only isn't it? You'd either have to Bootcamp Windows and turn your mac into a Win PC... or it maybe someone can get it working with Wineskin, since the Benchmark tool thing seems to work according to one report...
    http://appdb.winehq.org/objectManager.php?sClass=version&iId=25945
    of course thats no guarantee it'll be easy or possible to get the actual game working, but its new enough not many people have tried or reported their findings.
     
  3. robinthoms2 macrumors newbie

    Joined:
    Jun 9, 2012
    #3
    This thread is relevant to my interests.I'm curious to see the best way to run PSO2 without buying a windows machine.
     
  4. softypolimer, Jul 7, 2012
    Last edited: Jul 7, 2012

    softypolimer macrumors member

    Joined:
    Apr 21, 2009
    #4
    Currenly there is windows version only so your chance to play on osx is ether running it on wine or crossover game. You can count bootcamp too for running windows on mac.

    I would love to see pso2 on mac too, natively. However I'm a die hard fan for PSO, This game might convince me to install bootcamp or get a new PC just to play it.
    Right now I'm waiting to see ios or vista version. Also there's a little hope for it coming to ps3.

    Edit:
    You can also try latest VMware or Parallel Desktop but still recommend wine cuz it's free
     
  5. Camwin macrumors member

    Joined:
    May 24, 2012
    #5
    Bootcamp is easy to do and I'd suggest it. Sorry for the necropost.
     
  6. Lunfai macrumors 65816

    Lunfai

    Joined:
    Nov 21, 2010
    Location:
    Sheffield
    #6
    Also don't install Windows 8 RC, because it's not compatible with PSO2 yet, since there's a anti-hack verification system that hasn't been updated to support patching under Windows 8. :)

    There's no way around this, even if you emulate it under Windows XP/Vista/7, so just install 7.
     

Share This Page