PSSD not working for my T5 SSD any more

Dr. Dr. Evil

macrumors member
Original poster
Nov 9, 2018
37
17
Munich, Germany
Hi,
I have an T5 SSD on my Mac Mini without any problems. All works very well for me.
After buying i deleted the initial Samsung Software (portable SSD) when I checked it at the beginning, because I thought its useless for my needs.

Now I wanted to reinstall this SW piece for FW upgrade checking reason.
But suddenly the PSSD don't recognize the mounted T5 SSD on my Mac Mini

I already tried to
delete all extra partitions
changed files systems form OS Jornaled to NTFS to exFAT
changed the connecting usb-c cable

Nothing changed.

Any idea, why the Samsung SW does not see the T5 any more, though the MM play with the T5 without probs?

Thanks
 
Last edited:

IngerMan

macrumors 65816
Feb 21, 2011
1,343
310
Michigan
Hi,
I have an T5 SSD on my Mac Mini without any problems. All works very well for me.
After buying i deleted the initial Samsung Software (portable SSD) when I checked it at the beginning, because I thought its useless for my needs.

Now I wanted to reinstall this SW piece for FW upgrade checking reason.
But suddenly the PSSD don't recognize the mounted T5 SSD on my Mac Mini

I already tried to
delete all extra partitions
changed files systems form OS Jornaled to NTFS to exFAT
changed the connecting usb-c cable

Nothing changed.

Any idea, why the Samsung SW does not see the T5 any more, though the MM play with the T5 without probs?

Thanks

I’ve erased my several times and formatted from exFat to Journaled and now I have it APFS encrypted. I have had where it’s mounted but when I installed the SSD software I had to refresh meaning unplug and plug in. Are you getting the request for refresh from the SW?
 

Dr. Dr. Evil

macrumors member
Original poster
Nov 9, 2018
37
17
Munich, Germany
Yes, the request from SW to plug SSD comes up.
But plugging out and in makes no difference.

I just wanted to check if there is a FW update available.

Interesting that only the specific T5 Samsung SW does not see the SSD.
The Mac Mini and Mojave has no problems at all.

I think I just have to forget the SW and don’t touch a running system
 
Last edited:

Dr. Dr. Evil

macrumors member
Original poster
Nov 9, 2018
37
17
Munich, Germany
thanks for the guidance. I did all of this steps you mentioned, nothing changed.
I connected the T5 with another MacBook and installed the SW - the SW works, now probs!
So I think this could have two reasons.
- The SW installation has some problem on my new MM, which I can't fix. Even with search tools and deleting all program packages in the system nothing changes. PSSD don't recognize the SSD.
- Other reason could be, that the SSD has a problem on the MM USB-C/TB3 connection, but also via USB 3.1.

AS the SSD has no problem apart of not being recognized by his own SW, I give up and use the SSD quite normal

Thanks
 

yukari

macrumors 6502
Jun 29, 2010
421
191
Like IngerMan, I reformatted my SSD to APFS encrypted before running the SW. I then unplugged and replugged before SSD was recognized.
 

addonexus

macrumors newbie
Jun 23, 2018
18
0
i had the same problem. Formatted the drive once I received it. Thought of checking for new firmware (which I don't see listed on Samsung website) by downloading the app. Plugged in the T5 but the app does not detect it.

One month later, I got another T5. This time, before formatting, I ran the app first. But still, it does not detect the new T5. I can't help but feel it is due to Mojave since it is relatively new compared to the app.

Anyway, my T5s are produced in Apr 2019. Are there newer firmware than this date?