psx4all - Games Not Showing Up

Discussion in 'Jailbreaks and iOS Hacks' started by Xian Zhu Xuande, Aug 5, 2010.

  1. Xian Zhu Xuande macrumors 6502a

    Xian Zhu Xuande

    Joined:
    Jul 30, 2008
    #1
    Hiya folks,

    I've used a number of ZodTTD emulators over the years but I'm having some fuss with psx4all on my iPhone 4. I read that it supports .bin and .iso, among other formats, and I've tried adding ROM files (/var/mobile/Media/ROMs/PSX/ - 777 according to Transmit) manually, or by downloading them through the emulator's built-in downloader. I've tried expanding the ECM files and leaving them intact. I've tried both ISO and BIN. No matter what I do there are no games showing up in my titles list.

    My first thought was that this is a permissions problem, but psx4all created the PSX folder itself, and its permissions are wide open.

    Any thoughts on this from some folks who have experience with it?

    Amusing sidenote: I actually own all the original titles for the games I've been trying to play (Final Fantasy VII in this case). I should probably have sold all the NES, SNES, PSX games over the years, but for some reason I kept them all.
     
  2. phixionalninja macrumors regular

    Joined:
    Jun 23, 2010
    #2
    Silly question, but I assume you have the BIOS in the same folder and with the same permissions? I have FFVII running using psx4all, here are the files in my /var/mobile/Media/ROMs/PSX/:

    - Final Fantasy VII (Disc 1).cue
    - Final Fantasy VII (Disc 2).cue
    - Final Fantasy VII (Disc 3).cue
    - Final Fantasy VII (E) (Disc 1) [SCES-00867].bin
    - Final Fantasy VII (E) (Disc 2) [SCES-10867].bin
    - Final Fantasy VII (E) (Disc 3) [SCES-20867].bin
    - scph1001.bin

    Permissions on all of those is 755, though I don't know if that's necessary for the .cue files. You definitely need to expand the ECMs.

    EDIT: There are also some save files, but those shouldn't matter to you.
     
  3. Xian Zhu Xuande thread starter macrumors 6502a

    Xian Zhu Xuande

    Joined:
    Jul 30, 2008
    #3
    Thanks for replying! I finally got it. I probably had the right combination set up a few times, but failed to notice it because psx4all does not actively monitor the PSX directory for changes (it seems). I had to end the psx4all process (via the iOS 4 task manager thing) and when I re-launched it the game appeared properly.

    Another note of value is that the downloader does not decompress 'ecm' files. I haven't checked again to see if it can read them, but that might be a source of frustration for some people who expect the built-in downloader to do the trick.

    Final Fantasy VII runs better on the iPhone 4 than I expected it would. Motion is actually quite smooth. Sound, not so much.
     
  4. phixionalninja macrumors regular

    Joined:
    Jun 23, 2010
    #4
    I'm pretty sure it can't read ECMs, it is kind of a pain in the neck, but oh well.

    I've actually found sound to be surprisingly good. Here's a gameplay video I took with sound: http://www.youtube.com/watch?v=qzYgjIGng3w. It lags slightly every once in a while, but otherwise seems fine. Occasionally there's an odd bug where it just won't work at all, on any save file. If I boot up the disk image directly and start a new game it comes back though, and then I can load any save I have and the sound still works. Very odd.

    Amusing anecdote: I didn't realize at first that the ECM utility had two .exes in the folder, ecm and unecm. I used the first one, and thirty minutes later ended up with a .bin.ecm.ecm. Not so useful.
     
  5. Drakdaddy macrumors member

    Joined:
    Jun 22, 2010
    #5
    Dont know if this applies for everyone, but I always have to respring in order for new games to show up. Also, it does read ECM. I was playing Megan Man X4, which was an ECM file.
     
  6. SingBlueSilver macrumors member

    Joined:
    Dec 7, 2007
    #6
    I seem to be having trouble. My games are showing up but I can't get them to work.
    I have in /var/mobile/Media/ROMs/PSX/:

    Final Fantasy VII [NTSC-U] [Disc1of3] [SCUS-94163].bin
    Final Fantasy VII [NTSC-U] [Disc1of3] [SCUS-94163].cue
    scph1001.bin

    I set all the permissions to 755, but I still can't seem to get it to work. The .bin file at first was .bin.ecm tried that out and that didn't work either. So I tried just deleting the .ecm to see if that would work and still no luck.

    Any help?

    EDIT: Nevermind, got it! :)
     
  7. apennismightier macrumors newbie

    Joined:
    Feb 26, 2012
    #7
    I made an image from the original FF7 Disc using Alcohol 120% using the Playstation profile. It works every time with ePSXe and I have the right BIOS, SCHP1001, which also works fine on my PC. It worked when I had an iPhone 3Gs on a previous version of PSX4ALL, but now, with PSX4ALL v4.0.10 on an iPhone 4S, it does the same thing as listed above.

    SCEA pops up, then goes to black.

    I realized that I had to change the names of the files to ALL lowercase, otherwise the images won't work, even the extensions need to be lowercase, including the BIOS file.
     
  8. Freezeter14 macrumors newbie

    Joined:
    Jan 25, 2014
    #8
    I was downloading a game psx4all it won't show up on saved games.how do I delete it
     

Share This Page