Public wifi problem

Discussion in 'iPod touch' started by theman22333, Feb 15, 2010.

  1. theman22333 macrumors newbie

    Joined:
    Feb 15, 2010
    #1
    I have a second generation jailbroken ipod touch with 3.1 firmware. Recently, a free public wifi router was put upin my neighborhood. I managed to connect to it, but when I try to do anything with it, like go onto the app store or itunes, it says Cannot Connect to iTunes, Invalid Argument. I have tried to renew the lease, forget the network and reconnect, reset the network settings, etc... Nothing seems to work

    I also know about the 169.254.xx.xx IP address. Please keep in mind that I don't have access to the actual router to change this.

    Plz help!!
    thx
     
  2. pcs are junk macrumors 65816

    Joined:
    Sep 28, 2009
    #2
    two reasons could be why you are getting this message.
    1. it is like one of those hotel or mcdonald routers where you need to agree, purchase an internet usage thing with them, or enter a password. you can figure this out by opening up safari. if it doesnt automatically load, try going to a website, it should redirect you to the login page.
    2. there is no modem hooked up to the router, there for no internet. this could be used for printer sharing, file sharing, etc. no internet though.
     
  3. fckm0nkey macrumors newbie

    Joined:
    Feb 22, 2010
    Location:
    In your head.
    #3
    I'm having the same problem. I'm able to join a network but I'm unable to browse the web, use any apps that use wifi properly. I've tried several hot spots but I'm getting the same error. My friend was able to use safari and itunes with no problem at all. What do I do? I just got my iPod touch yesterday. Should I have it replaced? Please help. :(
     
  4. WLS macrumors 65816

    Joined:
    Jul 10, 2008
    #4
    You need to tell your Touch to "forget this connection" There is a bad setting that you are trying to use and you need to delete it and force the Touch to relearn the connection. go to settings/wifi and the blue arrow for the details.
     

Share This Page