Pulling my hair out here...upgrade advice needed please!

Discussion in 'OS X Yosemite (10.10)' started by Dazzystar, Dec 26, 2014.

  1. Dazzystar macrumors member

    Joined:
    Dec 13, 2014
    #1
    Hi All,

    I have Mavericks installed on my iMac (late 2009 model) and have downloaded the Yosemite installer from the App store but each time I run it I get an error a few seconds into it installing:

    'This copy of the Install OS X Yosemite application can’t be verified. It may have been corrupted or tampered with during downloading.'

    I have tried re-downloading 3 times and each time I get the same error.

    Can anyone advise what's wrong?

    Thanks
    Daz
     
  2. infantrytrophy macrumors regular

    Joined:
    Oct 27, 2013
    #2
    Try this:

    Look in your applications folder to see if the "install OS X Yosemite.app" file is there. If yes, then either delete this file or move it to another folder. Then try to download the OS X installer again.

    I don't remember all of the specifics, but the short version is that the installer app, when downloaded, is placed in the applications folder. Upon execution (installation of OS X), the installer app is deleted. I'm thinking that if there is already a downloaded installer app in the applications folder, a "fresh" copy of the installer app may not be placed there. Perhaps removing the installer app will allow proper downloading and placement of good copy of the installer app.
     
  3. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #3
    Is the date of your computer ok (dec 26th 2014) ?

    You would get the very same error message is the date is wrong.
     
  4. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #4
    Yes, the date and time are correct.

    I've deleted the other installer and am in the process of downloading another copy.

    I'll let you know how I get on.
     
  5. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #5
    Well. Downloaded a fresh copy, started to install and it got down to 1 second then I got the same error!

    Not sure if this is relevant but it probably is when I click on repair permissions in disk utility it keeps on coming up with the same permission error with regards to Safari. It says it repairs it but if I click on Repair Permissions again I receive the same thing!

    In addition, I have now received a verify or repair permissions failed error in red. This is a brand new hard drive I should add.

    Help needed!
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    Restart the Mac and hold Cmd + r on chime in order to boot up from the Recovery partition.

    From the OS X Utilities window, launch Disk Utility.

    Select Macintosh HD on the left, click "Repair the disc", and let us know what the result is.
     
  7. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #7
    Did that. Seemed to repair loads of things..went too far to make a note of anything though.

    Now, when I try and download Yosemite again from the App store it comes up straight away with OSX Failed to download. Use the purchases page to try again. I've tried 10 times !
     
  8. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #8
    Do you still have an "Install OS X Yosemite" from your previous download, in your Applications folder ?

    If yes, run it.
     
  9. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #9
    No. That's been deleted unfortunately.

    ----------

    I do seem to be getting consistent errors on repair permissions with iCloud if that helps?
     
  10. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #10
  11. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #11
    I created a new admin account, downloaded the YM installer and still the same error!

    ----------

    I should have added the error is the original verification, tampering with, error!
     
  12. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #12
    Maybe there's a server-side error at the moment. You might wait a few days and then try it again.
     
  13. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #13
    Here's a copy of the error:

    2014-12-26 21:51:59 +0000: Repairing permissions for “Untitled”
    2014-12-26 21:52:01 +0000: Permissions differ on “Applications/Safari.app/Contents/Resources/Safari.help/Contents/Resources/index.html”; should be lrwxr-xr-x ; they are -rwxr-xr-x .
    2014-12-26 21:52:01 +0000: Repaired “Applications/Safari.app/Contents/Resources/Safari.help/Contents/Resources/index.html”
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/th.lproj/iCloudSetupTopLevel.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/th.lproj/iCloudSetupTopLevelViews.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/Castle.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleLockedView.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleLockedViewTopLevel.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleReauthView.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleServiceRow.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleServicesView.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleUnavailableView.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleUnavailableViewTopLevel.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleUnverifiedView.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/IACastleUnverifiedViewTopLevel.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/iCloudAccountDetailsView.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/iCloudSetupTopLevel.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/tr.lproj/iCloudSetupTopLevelViews.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/uk.lproj/Castle.nib
    2014-12-26 21:54:37 +0000: Open error 18446744073709551594: “Unknown error: -22” on System/Library/InternetAccounts/iCloud.iaplugin/Contents/Resources/uk.lproj/IACastleLockedView.nib
     
  14. Ravenis macrumors member

    Joined:
    Feb 4, 2014
    #14
    Indicates an issue with iCloud in the Internet Accounts section, maybe corrupt plist? Maybe look into make USB bootable version in the meantime or use another mac if possible?
     
  15. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #15
    That error was from a newly created admin account.

    Is there a way to fix plist problems?
     
  16. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #16
    also, would that prevent Yosemite from installing?
     
  17. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #17
    The installer verifies probably the digital signature of the installation .dmg file and uses an old or invalid security certificate from your keychain.

    Are you a registered developer or do you use apps which install their own security certificates (VPN and E-mail security software, for example)?

    Here are some possible solutions (if it is a security certificate bug):
    http://support.gpgtools.org/discuss...lled-becaues-its-digital-signature-is-invalid
     
  18. Dazzystar thread starter macrumors member

    Joined:
    Dec 13, 2014
    #18
    No. Not a developer and Mavericks is a fresh and clean installation on a brand new hard drive.

    ----------

    I'd welcome anyone to take a look via Teamviewer if they have the time.
     

Share This Page