Purchased App wont install on other devices

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cosmichobo, Dec 7, 2013.

  1. cosmichobo macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #1
    G'day,

    Sorry, I'm sure there's other threads about this, but I can't find them...

    I have at least 2 instances of apps that I've paid for, using the 1 and only iTunes/Apple ID that I have ever owned, that will not allow me to access for free on my other iOS devices...

    Tetris, and Activity Monitor.

    One was downloaded about 3 years ago on my original iPhone3GS, the other only a few months ago when I got my iPad. I can use the apps on each of those 2 devices, but if I try to access them via the App Store on my other iOS devices, it wants me to pay again. (IE it says to buy for $x, rather than the cloud download button).

    I've tried logging out then back into my Apple ID on all of the devices... No good. The apps don't show up on the list of purchased apps on the other devices.

    How do I resolve this?

    (The apps shows up on my iTunes app on my MacBookPro... When I tried clicking the "Instal" button with my iOS device connected, it looked like it was trying to wipe everything off the device, except for that 1 app?!)

    Thanks for your assistance,

    cosmic
     
  2. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #2
    Sorry! Ignore me...

    "Tetris" apparently is different from "Tetris for iPad"... $2.99 vs $0.99... as I just found out when I went ahead and bought "Tetris" on my iPhone, thinking I'd get a message saying it was a free purchase as I'd already paid for it...

    I also gather Activity Monitor has an iPad version...


    cheers
     

Share This Page