Purchased TV Show Artwork Missing in Cloud

Discussion in 'Apple TV and Home Theater' started by TooDarkPark, Oct 4, 2018.

  1. TooDarkPark Suspended

    TooDarkPark

    Joined:
    Nov 23, 2017
    #1
    About 90% of my purchases TV shows are missing icons when I go to my purchases in the iTunes store on all three of my 4K Apple TVs in my house. This is only happening to the TV shows and not my purchased movies also stored in the cloud.

    I've tried logging out and then back in as well as completely resetting one of the Apple TVs and the problem remains which leads me to think this is an iTunes/Apple problem.

    Two of my Apple TVs are in the basement and both are fed with an ethernet connection with one modem coming in through a completely different line then the upstairs Apple TV which also has it's own model with ethernet cable going to that ATV.

    Anyone else seeing this or know how I can fix this if it isn't an Apple problem?

    IMG_0845.jpg
     
  2. steve23094 macrumors 68020

    steve23094

    Joined:
    Apr 23, 2013
    #2
    It happens sometimes and normally fixes itself. Sometimes I find a restart helps pull them down.
     
  3. TooDarkPark thread starter Suspended

    TooDarkPark

    Joined:
    Nov 23, 2017
    #3
    Just tried again and even rebooted, still missing the artwork. Hopefully it comes back soon.
     
  4. Tech198 macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #4
    I have the same sometimes, but "no purchases" when i go to TV Shows/Purchases

    And other times ok... I though it was my router and some funky dns issue... but perhaps not
     
  5. HobeSoundDarryl macrumors 604

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #5
    I had this and tried everything on :apple:TV with content I made and tagged myself. Ended up having to go into iTunes where movie posters also appeared to be missing when the movies were "view as" GRID. Right click on the problematic ones (the ones missing their poster), "movie info", "Artwork" tab, touch the poster (to put the blue outline around it), click OK. Movie poster then appeared in iTunes, GRID view. Went back to :apple:TV and it appeared there too.

    It appears you have to "touch" each file missing it's poster to make it work as it has worked for years now.
     
  6. TooDarkPark thread starter Suspended

    TooDarkPark

    Joined:
    Nov 23, 2017
    #6
    That always works for shows stored on my computer but not for shows bought and stored on the cloud unfortunately. The problem is still happening today.
     
  7. HobeSoundDarryl, Oct 9, 2018
    Last edited: Oct 9, 2018

    HobeSoundDarryl macrumors 604

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #7
    Experiment? What happens if you download one stored in the cloud? Then try that. Then delete it from local storage so it's in the cloud again? Does :apple:TV "find" the poster again?

    Yes, this is a hassle. But the alternative is waiting for Apple to do something on their end... which could be a long, long wait. Of course, report it to Apple as a probable bug but, in my experience, the bug list gets pretty slow attention too. So the choices are try what you are able to try yourself and see if you can resolve the issue or just roll with it until maybe Apple gets around to doing something.
     
  8. Killerbob macrumors 6502a

    Killerbob

    Joined:
    Jan 25, 2008
    #8
    The same problem with music, and it has been a nuisance for years, actually since Apple Music. I have hundreds, if not thousands of albums ripped from my CDs, and I have assigned album art to each and every one of them. Then when I syncronised with Apple Music the first time, about ⅓ of it just disappeared. I can’t even go in and “search for missing album art”. Also, now I have a high number of incorrectly assigned album art, whereas before it was correct.

    And, reporting it to Apple? I have done that several times, and they simply do not give a ****.
     
  9. jnlauderdale macrumors newbie

    Joined:
    Jun 10, 2011
    Location:
    LA
    #9
    --- Post Merged, Oct 9, 2018 ---
    Happening to me as well. Been ongoing for several days. Restarting and plugging and unplugging various modems not working. Had Apple said anything?
     
  10. elbartino macrumors member

    Joined:
    Apr 21, 2015
    #10
    I’m having this issue also very annoying


     
  11. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #11
    I just filed a bug report about this problem. Like others, logging out and resetting the Apple TV did not do anything to solve the problem. It was working fine before 2 weeks ago etc. Really annoying to have missing purchased artwork.
     
  12. a.jfred macrumors 6502

    Joined:
    May 28, 2010
    Location:
    Austin, TX
    #12
    I'm having the same issue with my AppleTV - Not all are missing, but most of them are. iTunes library on my computer, phone & iPad are fine, it's ONLY the AppleTV, which leaves me believing it's something to do with the recent update.
     
  13. seanrt macrumors member

    seanrt

    Joined:
    Jan 8, 2015
    Location:
    USA
    #13
    Same thing going on with my purchases when on AppleTV, nearly 3/4 of my purchases are missing artwork.
     
  14. DocStone macrumors regular

    DocStone

    Joined:
    Nov 27, 2006
    Location:
    Republic of Texas
  15. MacUser09 macrumors regular

    Joined:
    Sep 26, 2009
    Location:
    UK
    #15
    The same thing happened to me as well on my ATV 4K running 12.0.1.
    Movies are OK. Only affects TV shows. Only 15 out of 165 showing. Where thumbnail should be, there are just greyed out tv icons. If I click on some I can play the show. Others sometimes say "Could not play due to an error."

    Everything still there on my Macbook though.

    Tried both signing out of iTunes, and resetting ATV. No change.
     
  16. Jayderek macrumors 6502

    Jayderek

    Joined:
    Jun 28, 2010
    Location:
    Madison, WI
    #16
    happens occasionally for me as well - like others here I've tried different things. I'll be filing a report too
     
  17. HobeSoundDarryl macrumors 604

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #17
    Shaping up to be THE big innovation rolled out at next summer's WWDC: "We are soooooo excited to announce that tvOS 13 will add image thumbnails for each video! We made a 6-minute commercial to tell you about it and I'd like to show it to you now..." (commercial going on and on about video image thumbnails).

    Lights come back up: "Look at these beautiful posters to highlight each video... just beautiful... and these amazing posters are headlining over 3 new features in tvOS13... available later this Fall"

    I'm joking of course... but barely. I'm actually fearing that that may play out.;)
     
  18. HailstormX macrumors regular

    Joined:
    Nov 21, 2012
    #18
    Having the same problem. Tempted to try 12.1 beta
     
  19. hick9 macrumors member

    hick9

    Joined:
    Apr 5, 2011
    #19
    I've been writing Apple and complaining about this for close to a year. All the TV content I made and tagged myself that's in my iTunes refuses to display the artwork on my AppleTV 4K. My Movies Display just fine. From my experience it also seems to be an AppleTV 4K issue. In addition to my AppleTV 4K I have (2) Generation 4 and (2) Generation 3 AppleTV's and the artwork displays with no issues.
     
  20. HobeSoundDarryl, Oct 18, 2018
    Last edited: Oct 18, 2018

    HobeSoundDarryl macrumors 604

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #20
    For content you make yourself, hop into iTunes. You'll probably see that the artwork (poster) appears to be missing on the "grid view" page too. However, "Movie Info" or "TV Show Info" the files with missing artwork, "Artwork" and the image will be there. Click on the image. Then close the "movie info" window. It should reappear in iTunes "grid view". If it does, it should reappear on an :apple:TV4K screen too (possibly after a restart if not immediate). This workaround works for me.

    Yes, it's a pain to have something that has "just worked" for years and years to suddenly stop working (and only seemingly selectively with SOME files). And yes, it's a BIGGER pain if you have a LOT of homemade content and many are now missing their thumbnails. But submitting and then waiting on Apple to get around to fixing :apple:TV bugs can be a very long wait. Find your own solution, just live with Apple's choices or give up on Apple and move on to something that is somehow able to get much more focus from companies with much less cash on hand.

    For example, once long ago "fast scroll" worked really well. Then Apple decided to "improve" from showing a list of media to showing the thumbnails for each piece of media. Now "fast scroll" is an exercise in start & stop & start & stop. Why? Because the code is apparently prioritizing the loading of thumbnails from scratch EVERY TIME vs. just storing the bundle of relatively tiny jpegs in that 32GB or 64GB we paid for (or just sticking with what was "just works" lists without thumbnails). Of course, good chunks of that GB will be allocated to slow scrolls of beaches or buildings... but let's NOT allocate a little space to hold thumbnails locally so that (NOT) fast scroll doesn't have to stream all that over from the master computer each & every time.

    I so miss "just works" Apple. Bugs are natural- nothing is perfect- but it's tough to see "2XX Billion in the Bank" posts and "Another best-ever record quarter" statements while relatively simple features of a relatively small number of products are broken... for long periods of time. It's not like Apple is broke and/or lacks talent. Does everybody there have to focus on only 1 thing at a time?
     
  21. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #21
    The bug report I filed ended up being a duplicate from someone having already filed.

    My artwork is showing today.
     
  22. ImAnAgent Suspended

    ImAnAgent

    Joined:
    Oct 11, 2018
    Location:
    My mind
    #22
    I've been having the same problem for a few weeks. The TV show artwork is back now but everything stored on apples servers loads so slow or not at all.
     
  23. TweeterGuy macrumors newbie

    Joined:
    Oct 21, 2018
    #23
    How is the video quality compared to Netflix?
    T
     

Share This Page

22 October 4, 2018