Push and Fetch Have Stopped Working

Discussion in 'iPhone' started by bg.nashville, Jan 12, 2012.

  1. bg.nashville, Jan 12, 2012
    Last edited: Jan 12, 2012

    bg.nashville macrumors newbie

    Joined:
    Jun 24, 2009
    #1
    Does anyone know how to fix this problem? The only way I get anything is to open the mail app. When I do, I get an avalanche of notification alerts. Everything has worked perfectly until today. I have several different e-mail accounts and the problem affects all of them.

    This is happening on both my iPhone and iPad.
     
  2. juliuspierpont macrumors member

    Joined:
    May 11, 2007
    #2
    This happened to me a few times too. No idea why, but what worked for me was to go into settings/mail, and deactivate my accounts one at a time. Deactivate, not delete! After that, open the mail app, and you should be presented with the opportunity to set up a new mail account. At that point, close the app, go back into settings, and reactivate your accounts.

    I'm sorry if that isn't quite the right process. There is at least one thread about this on macrumors, and perhaps a search will turn it up.
     

Share This Page