Push comes to iPhone but not my iPad 2 ?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by LevMac, May 4, 2011.

  1. LevMac macrumors 6502

    LevMac

    Joined:
    Feb 23, 2008
    Location:
    QLD, Australia
    #1
    Hey guys, hoping you can help me out here, I have done some research online and went through Apple Discussion Forums, yet to no avail :(

    I have an iPhone 4, iPad 1 and an iPad 2 which are all set up with my Mobile Me account with "identical" settings to one another, with PUSH enabled on all devices...

    Now the funny thing is, my iPhone 4 and iPad 1 all make a "sound" notification when an email comes through, yet my iPad 2 doesn't even notify me !!

    It is driving me insane, I have removed the account from the iPad 2, even did a full Restore through iTunes and is running the latest Software Update...

    What the hell am I doing wrong ?!?!?!
     
  2. thunderbunny macrumors 6502a

    thunderbunny

    Joined:
    Jul 15, 2010
    Location:
    Cheshire, UK
    #2
    Does it display the badge notification and no sound, or nothing at all?

    Obvious questions - you do have the mail sound turned on? And there is no problem with other sounds?
     
  3. dacapo macrumors 6502

    Joined:
    Jan 25, 2010
    #3
    Same thing here!

    Side by side, my iPhone gets all the notifications and autodeletes the notifications if I happen to read the mail from my laptop or whatever. But the iPad2... it's either very laggy or something. It doesn't always get the notifications, and even after I've read the emails from elsewhere, the new mail notifications still remain on the iPad2.

    Anyone else experience this and figure out how to get around this?

    Edit: I'm not sure if this is the best forum to post this in. I'm going to copy&paste to the iPad forum.
     
  4. iLuvMyMacToo macrumors regular

    Joined:
    May 18, 2010
    Location:
    Australia
    #4
    Yep I have the exact issue. My mail doesn't come through unless I open the Mail app on my iPad2.

    Anyone know a resolution?
     
  5. ugahairydawgs macrumors 68020

    ugahairydawgs

    Joined:
    Jun 10, 2010
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    I am having a similar problem. I will get a new message and it will show up on my iPhone and iPad, but if I delete the message on the iPhone it doesn't automatically update the badge on the iPad. I have to manually open the mail app to get it to refresh.
     
  6. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_2 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8H7 Safari/6533.18.5)

    Same here
     

Share This Page