Push doesn't work on wifi (cell connection only)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by klub242, Sep 16, 2009.

  1. klub242 macrumors newbie

    Joined:
    Sep 16, 2009
    #1
    I bought my 3GS on Monday, push worked fine when i got it. Jailbroke it, push didn't work at all. Restored to 3.1, push works on 3G/EDGE but not wifi. Restored again, still doesn't work on wifi. The problem is I have no cell reception at home, so push working on wifi is pretty important to me. Is there anything I can do other than exchange my phone at the ATT store?
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Not jailbreak you phone? I have my phone officially activated after pwning it, and push isn't working at all for some reason. It doesn't even show up. It would easily show up by legitimately activating in during the jailbreak process but pwnage tool/3.1 still broke it. Oh well.
     
  3. klub242 thread starter macrumors newbie

    Joined:
    Sep 16, 2009
    #3
    Right, so I unjailbroke it, and just a little bit ago figured out I really don't think the problem is from the jailbreak. I went and tested push over wifi at a few different places (my church, school, and the library). It worked over wifi at all of those places. So basically the problem is specifically with MY home wifi for some reason. Does anyone have any clues how to fix this? A port that needs to be forwarded, for example.

    EDIT: Also my dad has a 1st-gen iPod touch with push support that gets occasionally used on our home wifi. Could that have something to do with it? (and he's had his ipod on our network long before i've had my phone, and push works for him... or it used to several months ago last i checked)
     

Share This Page