Push email delays

Discussion in 'iOS 10' started by whsbuss, Oct 12, 2016.

Thread Status:
Not open for further replies.
  1. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #1
    Over the past couple of days I've noticed emails not getting pushed to my IP7 on iOS10.1 - I get it on my Mac mail but unless I open the iOS mail app it doesn't appear. Yes I made sure Push is set in settings. I see it mostly on the iCloud account.
     
  2. oMc macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #2
    Some people mentionned it too in the iOS 10.1 beta 3 thread, I think.

    However I don't think it's related to 10.1 beta but rather to iCloud, because I noticed it too on my iPhone 6 which is running iOS 10.0.2.
     
  3. colburnr macrumors regular

    colburnr

    Joined:
    Feb 4, 2011
    Location:
    Crown Point, IN
    #3
    This...I am having the same problem, but I am also still on 10.0.2
     
  4. oMc macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #4
    Apparently desactivating and re-activating Mail in the iCloud options solved the issue for some people. Haven't tried yet.
     
  5. colburnr macrumors regular

    colburnr

    Joined:
    Feb 4, 2011
    Location:
    Crown Point, IN
    #5
    Thanks...I tried that, but it didn't work.
     
  6. whsbuss thread starter macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #6
    Tried signing out and back into icloud but it still delays at times.
     
  7. colburnr macrumors regular

    colburnr

    Joined:
    Feb 4, 2011
    Location:
    Crown Point, IN
    #7
    I think it might actually be the mail app itself. I downloaded Email by easilydo and I am receiving my emails pushed to me. Not sure what to think...
     
  8. whsbuss thread starter macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #8
    Took a few tries (icloud address w/different AppleID) but I added iCloud to my Outlook app on my iPhone. Lets see what happens

    EDIT: just noticed that read updates happen in realtime on the Outlook app for iCloud. So why doesn't the Mail app ?????
     
  9. starkillers macrumors member

    Joined:
    Sep 17, 2015
    #9
    I've also been affected by this the last few days. Tried everything and no luck. Was working just fine up until a few days ago.
     
  10. jbachandouris macrumors 601

    jbachandouris

    Joined:
    Aug 18, 2009
    Location:
    Upstate NY
    #10
    It's crazy that it takes adding iCloud to the Outlook app to get our mail on time. There really needs to be a better solution.
     
  11. starkillers macrumors member

    Joined:
    Sep 17, 2015
    #11
    I contacted Apple and had them duplicate the same issue on the tech's phone. Was told they do indeed see the same issue and put a ticket in for this. Appears to be some sort of apple server side error pushing the iCloud emails to the iPhone. Let's see how long this nasty bug persists.
     
  12. M. Gustave macrumors 68000

    M. Gustave

    Joined:
    Jun 6, 2015
    Location:
    Grand Budapest Hotel
  13. oMc macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #14
    Me neither with my professionnal email account, and my company is using Exchange.

    By reading reports of people here in different thread (this one, the link above and in the iOS 10 beta thread) I think it's only related with iCloud.

    And because different people using different devices under different iOS versions are reporting the issue, it's almost certain it is related to Apple servers not doing the job properly.
     
  14. ilkevinli macrumors 6502

    ilkevinli

    Joined:
    Apr 8, 2006
    Location:
    NYC
    #15
    I have had this issue on both 10.0.2 and 10.1. It has been driving me crazy.
     
  15. LordQ Suspended

    LordQ

    Joined:
    Sep 22, 2012
    #16
    I have this issue on my 6s (10.0.2) - email is delivered instantly on my iPad (5.1) but delays around a minute on the iPhone. Most odd.
     
  16. jbachandouris macrumors 601

    jbachandouris

    Joined:
    Aug 18, 2009
    Location:
    Upstate NY
    #17
    On my 7+, mail wouldn't show up at all unless I opened the Mail app. Seems to be working today, but who knows...
     
  17. whsbuss thread starter macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #18
    It is strange. I sit here and get email notification on my mac using the Mail app, and it takes minutes to get it on my iPhone. And just a few minutes ago, it was the opposite.
     
  18. sdlevi27 macrumors regular

    Joined:
    Oct 22, 2008
    #19
    +1. Thought I was the only one. Running 10.1 beta. Seems like it's a server side problem and not a device issue.
     
  19. DrumApple macrumors 6502

    Joined:
    Jan 30, 2009
    #20
    Using the iOS 10 Mail app with my work Exchange account, it says it Pushes but it really feels more like it fetches. Usually only updates when I open the Mail app, or every hour or so. This is where the Outlook for iOS app shines, I get my mail in real-time push fashion, like my old Blackberry status usually.
     
  20. starkillers macrumors member

    Joined:
    Sep 17, 2015
    #21
    im wondering how many others are affected by this? Or simply not aware of this. One can easily check by turning off iPhone screen for about 30 seconds allowing phone to sleep. Must be asleep to truly tell if push mail is doing its job. Then send an email from other source, laptop, iPad etc. The push email should alert the iPhone within 10 seconds. Still broken as of today for me. Going on about 3 days now.
     
  21. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #22
    Mine broke 3 days ago as well. I thought it was iOS 10.1 related but when I went back to 10.0.2 the issue returned after a few hours.
     
  22. DrumApple macrumors 6502

    Joined:
    Jan 30, 2009
    #23
    Honestly I'm not sure it's ever worked in true Push fashion for me. Apple has a different definition of "Push" I think - or is missing some key functionality on Exchange accounts which I doubt they'll ever fix.

    In fact when I have both Outlook for iOS and Mail on, Outlook gets it first and then it triggers Mail.
     
  23. whsbuss thread starter macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #24
    Well lets all submit a feedback to Apple. That way they can investigate what the heck is happening. I have noticed that its fine for a bit of time, and then my Mac gets emails delivered and nothing on the iPhone.
     
  24. starkillers macrumors member

    Joined:
    Sep 17, 2015
    #25
    Push was working directly into the mail app. I would notice both emails on my mac and my iPhone within seconds of each other. Right now, as it stands, I'm not even getting some emails unless I open the app to refresh. Don't know how exchange affects anything, but it indeed was previously working right into the mail app.
     
Thread Status:
Not open for further replies.

Share This Page