Push email on iPhone

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by mattpreston11, Oct 15, 2011.

  1. mattpreston11 macrumors 6502a

    Joined:
    Nov 9, 2007
    #1
    Simply isn't working properly on my iCloud account.working brilliantly on mobile me.

    Anyone else having issues?
     
  2. marine0816 macrumors 6502a

    marine0816

    Joined:
    Mar 11, 2011
    Location:
    USA
    #2
    icloud is over hyped non sense, I thought I would use it exclusively but that changed. Sticking with Gmail and Dropbox
     
  3. KenOzz macrumors member

    KenOzz

    Joined:
    Aug 2, 2011
    Location:
    Lincoln UK
    #3

    Yes me too, :(

    I migrated my MobileMe account across to iCloud and have had consistent problems with email since, I have now set iCloud to forward my emails to Gmail until Apple sort it out

    I set up MobileMe in January 2011 and luckily kept my Gmail account , so I am switching it all back now, MobileMe was a disappointment for me, and I had hopped iCloud would be better well its not

    My iCal and contacts sync ok but all the rest is patchy so Gmail and Dropbox for me now its a pity as I really wanted to be all Apple, maybe they will sort it out eventually

    One good point though by forwarding all my mail from iCloud to Gmail the mail notification on my iPhone and iPad update in real time :)
     
  4. mattpreston11 thread starter macrumors 6502a

    Joined:
    Nov 9, 2007
    #4
    Think I have sorted my incoming push issue.

    settings - icloud - account - advanced(mail) - outgoing mail server - icloud SMTP server (on)

    Not sure why this would have an effect on incoming mail (with it being the outgoing server settings) But all seems to be working now.

    I think it was an issue with my migration, because even my fetch schedule was not being processed automatically. Seems to be working now, I came from a mobile me account by the way.

    Hopefully this will help someone else :D
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Mine seems sporadic also. I would not change any settings from the default. I suspect Apple is still fine tuning things on their end.
     
  6. benmrii macrumors 65816

    benmrii

    Joined:
    Nov 14, 2007
    Location:
    NC
    #6
    Thanks, though having the same issue and those were already my settings. Oddly the issue is only occurring on my iPhone, whereas my iPad running iOS 5 is not having the same issue.

    I hope yours is working now, but I fear it's more likely the issue, being sporadic, is just gone sometime after you tweaked settings that have nothing to do with receiving incoming push emails. :)
     
  7. LxHunter macrumors 6502

    Joined:
    Nov 14, 2010
    #7
    Try setting up the iPhone email account @me as an Exchange account to enable push.
    The instructions are on a Google page.
    Note the setting m.google.com
     
  8. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #8
    I notice this very same issue. I also Noticed I had turned off New Mail Sound because I have it on my desk a lot and got tired of hearing it while also seeing the red badge on my computer Mail App. I mention it to be complete but I do not believe it was the cause. What I did was to turn the sound back on for testing and then I turned Mail off and then got out of Settings and then went back in and turned Mail back on (iCloud Mail Setting). Then it starting working. But strangely my iPad Stopped working. Then I did the same on my iPad and now both are working (i.e. Email is being Pushed). You may want to give it a try.
     
  9. benmrii macrumors 65816

    benmrii

    Joined:
    Nov 14, 2007
    Location:
    NC
    #9
    Thank you for the details! Tried it and unfortunately it didn't work for me (still pushing to the iPad but not the iPhone). Glad it is for you, though.
     

Share This Page