Push email problems with 5.1?

Discussion in 'iOS 5 and earlier' started by newdeal, May 5, 2012.

  1. newdeal macrumors 68020

    Joined:
    Oct 21, 2009
    #1
    I am having some serious issues with push on 5.1. Doesn't matter if I am on wifi or cell network push is not working properly. I have tried resetting network settings and restarting the phone and force closing mail and deleting my account and re entering it and nOthing seems to work. Occasionally it will push but the majority of the time it does not. Doesn't seem to be as bad on my new iPad as it is on the iPhone. I have tried a 4 and a 4s and both are hit or miss. My 4s came with 5.1 and I have no way to dOwngrade it but this is very frusterating. I can't get push with iCloud or gmail or hotmail (both as exchange) and the settings are the same as on my iPad which works much better. Any suggestions?
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    What mail service are you using? Imap or POP? My Gmail works fine on my 4S and iPad....I have 3 email addresses using that service, and a couple on the @me cloud service....That one doesn't work all the time, but as I only use it for unimportant mail it makes little difference.

    If your imap port settings are correct, try changing the the timing on each device. If that improves reliability, then shorten the push time....Mine is set to every 15 minutes, but try 30 at first...Easy to test by sending yourself a mail to each address...Then shorten to 15 if that works for you.
     
  3. newdeal thread starter macrumors 68020

    Joined:
    Oct 21, 2009
    #3
    The fetch interval has nothing to do with push. It should be instant but it isn't for me. I have tried iCloud gmail and hotmail and none work properly
     
  4. ajvizzgamer101 macrumors 65816

    Joined:
    Mar 3, 2008
    Location:
    United States
    #4
    Same problem... Does it to my iPad and iPhone all the time. Force quit the mail app and turn the mail toggle off in the settings for a few minutes and then back on... works for me but it's only a temp solution though, so don't get to frustrated if it happens again.
     
  5. FlatlinerG macrumors 6502a

    FlatlinerG

    Joined:
    Dec 21, 2011
    Location:
    Ontario, Canada
    #5
    Be sure to check Settings>Mail, Contacts, Calendars>Fetch New Data>Advanced, that each account is actually set to push.

    Most people tend to overlook this section as they just don't go to advanced because they set push to on.
     
  6. newdeal thread starter macrumors 68020

    Joined:
    Oct 21, 2009
    #6
    Yes all the settings are correct. My iPad isn't as bad it seems to push to the iPad most of the time with the same settings but the iPhone really won't push at all.
     
  7. Electric turd macrumors member

    Joined:
    Mar 30, 2011
    #7
    What you are describing isnt push mail. You are talking about fetch.....2 diff things
     
  8. newdeal thread starter macrumors 68020

    Joined:
    Oct 21, 2009
    #8
    Killing mail seems to allow the push to work but once it restarts push stops again so I have to kill it each time
     
  9. caccamolle macrumors 6502

    Joined:
    Feb 18, 2005
    #9
    push is broken. It's been broken for many months. Everyone knows it.

    And Apple is not even acknowledging this huge problem.
     
  10. FlatlinerG macrumors 6502a

    FlatlinerG

    Joined:
    Dec 21, 2011
    Location:
    Ontario, Canada
    #10
    Push is not broken. If it were broken, it wouldn't work for anyone. Push works flawlessly on my iPhone running 5.1.


    OP, I'd try a reset all settings and if that doesn't work restore it as a new device and manually sync your content back to it but test it just after the restore. Avoid the backups.
     
  11. newdeal thread starter macrumors 68020

    Joined:
    Oct 21, 2009
    #11
    ...

    well it definitely isn't working for me on my iPhone. The new iPad is pretty good with the same settings and the same wifi network. the new iPhone I just got the other day unlocked and before that I had a iPhone 4 on 5.1 that experienced the same issue
     
  12. wayneholbrook macrumors regular

    wayneholbrook

    Joined:
    Mar 30, 2010
    Location:
    Miami Florida
    #12
    What you have been discussing has happened to me for several months. I have two iPhone 4S's and iPad 3. It happens on all devices now and again. Not all the time but every device of mine experiences it. For example, I will look at the device and it will show no new mail, but as soon as I open mail, Bam! Then I get like 15 pieces of mail all at once.

    People who don't rely on email that much maybe for personal use don't even notice, but when you depend on it for work then you notice it immediately. This has been on ongoing issue for sometime. I use to think it was the carrier but not when it happens on wifi as well. At least your not alone in this issue.

    And yes, I am talking about push not fetch. I know the difference.
     
  13. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #13
    Push is largely dependent upon your email provider.

    For example, I've found gmail to be amazingly responsive with push, as long as you're using the google sync (microsoft exchange) interface, and not the gmail interface (which doesn't have push, only fetch). Messages often get pushed to my iOS devices within 10-20 seconds of being sent. However, other exchange-based interfaces can vary widely in how quickly messages get pushed (one test took around 7 minutes). This is also true of the other push email providers: hotmail, yahoo, and icloud.
     
  14. newdeal thread starter macrumors 68020

    Joined:
    Oct 21, 2009
    #14
    ...

    Had you read my post yu would see it sucks with three different providers equally. Also I restored to 5.1 as a new iPhone and the issue persists
     
  15. scubus macrumors member

    scubus

    Joined:
    May 25, 2001
    Location:
    Orlando, FL
    #15
    For what it is worth, I have the same issue with my .mac email. It never pushes... it only checks my email when I manually check (and often I end up with 20+ emails all at once).

    Checked all my settings - still not working for me. It has been like this for weeks.
     
  16. caccamolle macrumors 6502

    Joined:
    Feb 18, 2005
    #16
    take a trip to Apple discussion forum and meet reality.
     
  17. FlatlinerG macrumors 6502a

    FlatlinerG

    Joined:
    Dec 21, 2011
    Location:
    Ontario, Canada
    #17
    Yes because every single person posts on an Apple discussion forum. What you read on the internet =/= reality. There are something like 25 million iOS 5 users. If you can get them to post that they are having legit push issues, not just because of incorrectly configured settings, come see me. Otherwise, you fail to understand that just because you are upset that push isn't working on your device doesn't mean that it's broken for everyone.
     
  18. newdeal thread starter macrumors 68020

    Joined:
    Oct 21, 2009
    #18
    ...

    Well 5.1.1 didnt fix it and it still works fine on my ipad. Occassionally it will work on my phone but only when it is on 3g not over wifi (on the same network that my ipad gets pushed pretty well on)
     
  19. scubus macrumors member

    scubus

    Joined:
    May 25, 2001
    Location:
    Orlando, FL
    #19
    I updated to 5.1.1 and one of the first things that happened was a set of emails came via push. Interesting issue - but I don't have the answer. At least mine seems to be working. Best of luck to you :)
     
  20. scubus macrumors member

    scubus

    Joined:
    May 25, 2001
    Location:
    Orlando, FL
    #20
    Nobody said it was broken for everyone. And just because it works for you doesn't mean there aren't real issues for others.

    Sadly, my push has stopped working again. And since I have changed no setting since yesterday when it was working, I suspect the problem isn't a setting.
     
  21. scubus macrumors member

    scubus

    Joined:
    May 25, 2001
    Location:
    Orlando, FL
    #22
    I don't think so, but that is exactly what my phone is doing. Hmmm....
     
  22. twigman08 macrumors 6502

    Joined:
    Apr 13, 2012
    #23
    Push is working flawlessly on my game. It is pushed to the device almost instantly. I had a place send me an email, so I went to log onto it from my desktop and before I could even get logged on it was pushed to my phone. I'm running 5.1 also.

    What accounts are you using? Gmail account doesn't support push, you must set it up via Microsoft Exchange to use push that way.
     
  23. grinny11 macrumors regular

    Joined:
    Aug 12, 2008
    #24
    I have a 4S, an iPad 2 and 3 and they all stop pushing email at some point.

    I also had gmail and then switched to .me account. Still would stop pushing. My mom has a yahoo push account on her iPhone 4. It stops pushing mail too. You can close out the mail program but eventually it will stop again.


    It's soooooo annoying.
     
  24. wsc9005 macrumors regular

    Joined:
    Dec 12, 2011
    Location:
    Scotland, UK
    #25
    Well.. Push service were never reliable on my iDevices ... I have an iPad 2, 3 and two iPhone 4s at home, email service and Facebook messages are suffering delays all the time, however, my lumia 800 and work phone blackberry 9900 works flawlessly with push email and push notifications from social apps.
     

Share This Page