PUSH email seems to make the iphone hot~

Discussion in 'iPhone Tips, Help and Troubleshooting' started by tivoboy, Jul 7, 2009.

  1. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #1
    What is wrong with push email on the iphone?

    So, if you haven't read my battery tests for the past week, you won't know the results.

    PUSH is the battery killer for me at least, PUSH email. Mobileme, or yahoo alike

    Then comes the GPS, duh
    Then comes the 3G data, but not as much as I thought previously.

    Well, WHAT is WRONG with PUSH? I thought that the highlight of PUSH was that it WASN'T a constant connection, but a server based association with the phone/tower and the server info. The NETWORK had a relationship with the tickle at the tower (on the data channel) and then server. Server knows, when it gets an email, boom send it here I'll find the phone.

    But, it almost seems that a seperate data connection from the phone is ON all the TIME? Of course, then sucking down the battery performance.

    The other thing I have noticed, and checked THREE times now, is that when I have PUSH enabled, the back of the phone GETS WARM, and when I turn it OFF, the back of the PHONE COOLS rather quickly. And is NOT warm at all.

    So, some of these heat issues COULD be tied to PUSH being on all the time.

    Will this ever be fixed or is this just the way it is going to work?
     
  2. Carnivor macrumors regular

    Carnivor

    Joined:
    Feb 24, 2008
    #2
    I may have a fix for this, im testing atm,

    my 3.0 ran hot, 5/6 hrs battery, signal constantly changing....

    but ive redone 3.0 3 times now based on others threads, and now i think the problem is ssl in mail settings, not push.

    every time ive setup my mobile me account, the phone has gotten hot and battery doesnt last past 5/6 hours. but this mornings 3rd time when setting up mobile me, the ssl verification failed, so i choose to carry on setup and not enable ssh.

    the only time ive seen that error is when i used to have a pop account and you have to go through the wizard and error before being able to turn ssl off as this old pop server didnt have ssh. say no, and it all works fine.

    So...

    42mins usage, Standby 2hrs 24mins, 3G on, Locations on, push mail on, push apps on, wifi off, bt off. iphone has been cold as stone battery indicator hasn't budged. and my signal has been solidly on the fat end of the 3g scale!

    I know its early days on my test but it seems to be behaving as if it was a vanilla setup, i have itweetie with push, and facebook apps only installed. the 42mins is a bit of video, bit of music, setup of apps and prefs, so nothing heavy load, but before it didnt need a heavy load to make it hot.

    try it it might make a difference to just not have ssh on and actually be able to use your iphone
     
  3. tivoboy thread starter macrumors 68030

    Joined:
    May 15, 2005
    #3
    will try

    I'll give it a try, isn't there a setting for this in MM?
     
  4. Carnivor macrumors regular

    Carnivor

    Joined:
    Feb 24, 2008
    #4
    Yep go into settings, mail, mobile me account, account info, advanced, under incoming settings.

    now usage 1hr 30 mins, standby 4hrs 3mins, still cold, looking good
     

Share This Page