push mail not working any more for me

Discussion in 'iPhone' started by velvetelvis, Jul 10, 2008.

  1. velvetelvis macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
  2. velvetelvis thread starter macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
    #2
    ive been thu all the steps. even managed to get into mobile me for a bit. and yet, still, push has stopped working for me. any help would be greatly appreciated.:D
     
  3. ubersalad macrumors 6502a

    Joined:
    Feb 26, 2008
    #3
    not working how? you have to provide more info.
     
  4. Devil's Refugee macrumors 6502

    Joined:
    May 14, 2007
    #4
    Not just email, push contact updates aren't working either.
    MobileMe can't be up and running 100% yet.

    Strange though, since I made a few calendar updates last night and it pushed through fine...
     
  5. ubersalad macrumors 6502a

    Joined:
    Feb 26, 2008
    #5
    Oh you guys are referencing MobileMe.

    My Exchange server is pushing through just fine.
     
  6. schatzie macrumors member

    Joined:
    Jan 30, 2008
    #6

    Can you guys tell me if your IT dept had to do anything for you to get direct push from your exchange server?
    I'm holding off on buying iPhone 3G until I know for sure it works with our company's. I have a coworker who just upgraded his iPhone to 2.0 and tried out exchange. He said he can get the mails fine but have to manually check it. He can't get direct push. I see quite a few of you have yours working with direct push, I was wondering is there any special setup you or your IT dept had to do.

    Thanks!!!!
     
  7. velvetelvis thread starter macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
    #7
    my push is just hit and miss.... but, since mobileme isnt fully functional, as in i can get in, but it wont pull up my email, i suspect, like many, that push will continue to be like this.
     
  8. Joe23 macrumors 6502

    Joined:
    Sep 14, 2007
    #8
    MobileMe push is flaky, Exchange is flawless - didn't have to change anything on the Exchange server for iPhone use.
     
  9. byron_hinson macrumors 6502

    Joined:
    Jun 3, 2003
    #9
    Exchange has been great for me too - working all the time
     
  10. Andrmgic macrumors 6502a

    Joined:
    Jun 27, 2007
    #10
    I noticed that exchange didn't work as well when it was connected to a wireless router at my office as it does when connected to the 3G network. I am thinking that the router is just a PoS... I get notifications at the same time or before Outlook when using 3G.
     
  11. mxpx5678 macrumors member

    Joined:
    Feb 11, 2008
    #11
    SOLUTION:

    I was having push issues also. This is a fix for MobileMe.

    What I did was go into the push settings and switched it to manual. I then went into the calendar and the contacts and let them update manually.

    Then I went back and set the settings back to PUSH. Turned off the iPhone and turned it back on. Push was then working properly for Contacts and Calendar.

    I followed the same steps to get PUSH working for email too.

    Hope this helps.
     
  12. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #12
    That doesn't solve the problem if MobileMe stays unreliable.

    The whole idea behind push e-mail is that you get your information without having to check its working or check the settings for it!

    Right now its not doing that! I hope Apple sorts it out...
     

Share This Page