Push no longer working for Yahoo Mail

tbayrgs

macrumors 604
Original poster
Jul 5, 2009
6,553
3,481
I've enabled Push for both of my Yahoo mail accounts for quite a while now (a year maybe) on both my iPhone 4 and iPad 2 and until about 2-3 weeks ago, never had any problems. I haven't changed any of my account settings or changed any of the mail settings on either device but now I only get my email if I open the app. I temporarily switched to Fetch every 15 minutes and was once again getting email messages without having to manually open the app but prefer the immediacy of Push.

Also, the fetch schedule is supposed to be used when Push doesn't work yet that doesn't seem to be the case either. If I go into the Advanced settings and set the Yahoo accounts for either Push or Fetch, I never automatically get email if the Push setting is set to On.

Anyone with similar experiences and if so, were you able to resolve it?
 

Tiptizzle

macrumors 6502
Apr 22, 2011
382
2
I've enabled Push for both of my Yahoo mail accounts for quite a while now (a year maybe) on both my iPhone 4 and iPad 2 and until about 2-3 weeks ago, never had any problems. I haven't changed any of my account settings or changed any of the mail settings on either device but now I only get my email if I open the app. I temporarily switched to Fetch every 15 minutes and was once again getting email messages without having to manually open the app but prefer the immediacy of Push.

Also, the fetch schedule is supposed to be used when Push doesn't work yet that doesn't seem to be the case either. If I go into the Advanced settings and set the Yahoo accounts for either Push or Fetch, I never automatically get email if the Push setting is set to On.

Anyone with similar experiences and if so, were you able to resolve it?
I had recently saw someone with the same problem on another forum. Have you posted this problem elsewhere?
 

rbgatti

macrumors member
Nov 1, 2011
37
1
USA
Mine started working yesterday after being non-functional for 2 weeks. All OK so far...
 

tbayrgs

macrumors 604
Original poster
Jul 5, 2009
6,553
3,481
I found another thread in the iPhone forums regarding the same issue and a few posters there had commented that it started working again yesterday so I re-enabled Push on my iOS devices--no luck until I powered them off and back on and voila, my Yahoo mail is once again being pushed.
 

Tibits

macrumors 6502
Feb 23, 2011
308
113
Yahoo Mail push has always had hiccups for my wife and I on all our iPhones. It seems like a few times a year it stops working for days at a time. Sometimes deleting and reinstalling the account helps and sometimes it resolves itself.
 

rbgatti

macrumors member
Nov 1, 2011
37
1
USA
Yahoo Mail push has always had hiccups for my wife and I on all our iPhones. It seems like a few times a year it stops working for days at a time. Sometimes deleting and reinstalling the account helps and sometimes it resolves itself.
In addition to this, I have found that the mail app stops working for no reason daily. I shut the app down and within seconds, mail starts pushing again. I believe this is an iOS 5 bug...
 

aham23

macrumors regular
Oct 31, 2011
230
0
like the others have said it has been down for several weeks for reasons unknown. this week mine started pushing again. like champ, super fast.
 

patrickw1995

macrumors newbie
Apr 24, 2012
1
0
same here this never happened to me before now i have to open the app to look at my email on my iphone. but push on my ipod touch still works perfectly i wonder who screwed up apple or yahoo.
 

thinkadam

macrumors regular
Oct 12, 2011
179
15
Canada
Anyone have an update on this?
I heard that removing iCloud can fix it, but that removes photo stream which is a nice to have.
 

tbayrgs

macrumors 604
Original poster
Jul 5, 2009
6,553
3,481
same here this never happened to me before now i have to open the app to look at my email on my iphone. but push on my ipod touch still works perfectly i wonder who screwed up apple or yahoo.
Anyone have an update on this?
I heard that removing iCloud can fix it, but that removes photo stream which is a nice to have.
I found another thread in the iPhone forums regarding the same issue and a few posters there had commented that it started working again yesterday so I re-enabled Push on my iOS devices--no luck until I powered them off and back on and voila, my Yahoo mail is once again being pushed.
Only suggestion I have is what I previously posted. I disabled push, hard reboot of the device and then re-enabled push. Both of my iDevices have been receiving mail from Yahoo via push since January so no idea what's causing your problems at this moment. And FWIW, I have iCloud enabled on my devices as well.