Push Not Working

Discussion in 'iPhone' started by kes601, Sep 16, 2008.

  1. kes601 macrumors regular

    Joined:
    Aug 3, 2008
    #1
    Anybody else having problems with Push mail not working since 2.1 update? I'd say 80% of the time I have to manually open the mail program for any mail to be downloaded.
     
  2. slate1 macrumors regular

    Joined:
    Sep 12, 2006
    #2
    yep me too - I've tried every fix I can think of including a full restore.

    I've had push off since the update with fetch every 15 minutes

    Hasn't really seemed to impact my battery life like I thought it would.
     
  3. WhySoSerious macrumors 65816

    WhySoSerious

    Joined:
    Jun 30, 2007
    Location:
    Dallas, TX
    #3
    2.1 push email working fine for me with MobileMe and Yahoo.
     
  4. abnospam macrumors regular

    abnospam

    Joined:
    Jul 17, 2008
    #4
    I have had this problem since 2.0 on 3g.
    Exchange + Yahoo. I just inactivated yahoo and it has been working nicely for 12 hours. My theory is that multiple accounts collide with themselves.
     
  5. kes601 thread starter macrumors regular

    Joined:
    Aug 3, 2008
    #5
    It started working for me sometime last night. We'll see if it continues today.
     
  6. iP2 macrumors member

    Joined:
    Feb 8, 2008
    #7
    Just adding my findings...

    I'm on 2.1 and my work Exchange 'push' works fine (just like before). But my two Yahoo accounts do not push anymore (which worked fine for me prior to the update). Have to manually update both Yahoo accounts to get new mail. This defeats the purpose of using Yahoo as a poor man's SMS client as its no longer somewhat instant. Not sure if that's a firmware bug or if Yahoo is having the problems.

    EDIT: My Yahoo push worked again w/o any changes done by me. It's on battery and auto-locked as usual. We'll see if this continues.
     
  7. kes601 thread starter macrumors regular

    Joined:
    Aug 3, 2008
    #8
    Stopped working again this morning.

    Edit: Thanks for the link to the Apple Discussion thread. I can confirm that mine works fine when connected to a power source, once it is disconnected from a power source, push and fetch stop functioning.

    Edit 2: Power source merely fixes fetch for me, not push.
     
  8. fatalcure macrumors newbie

    Joined:
    Jul 14, 2008
    #9
  9. Sweetbike40 macrumors 65816

    Sweetbike40

    Joined:
    Aug 29, 2007
    Location:
    NY/NJ
    #10
    I really love this iPhone and all but the e-mail fetching/push problem is really pathetic now. We must wait for yet another fix for a basic feature of a smartphone?:mad:
     
  10. manhattanboy macrumors 6502a

    manhattanboy

    Joined:
    Jan 25, 2007
    Location:
    In ur GF's bed, Oh no he didn't!
    #11
    Same problems for me...
    jesus this is going to be a sh*tty two years of crap updates.
    And FYI my calls have started dropping again...even on EDGE but I think that's AT&Ts fault because SIMming into different phone results in same sh*t.

    When are APPLE and AT&T going to get their act together?
    This is like a circus clown show.
     
  11. fatalcure macrumors newbie

    Joined:
    Jul 14, 2008
    #12
    hmm...fetched started working for me again today outta nowhere...i am now receiving my mail at the correct fetch interval...might have been an issue on apples/gmails end?

    edit: eh nvm, not working at all when not in use or not plugged in :/
     

Share This Page