Push notification doesn't work on home network!!

Discussion in 'iPod touch' started by eraysonat, Feb 9, 2010.

  1. eraysonat macrumors newbie

    Joined:
    Feb 9, 2010
    #1
    Hello everyone

    I have a brand new Ipod Touch (64GB) with OS 3.1.2 (not jailbroken or hacked). At home I have a modem-router Aztech DSL605EW, where my iMac is connected thru ethernet and 2 PCs connected wireless. When I get on this network my iPod gets push notifications only for my Mobileme account. My Facebook, WhatsApp, IM+ push notifications won't work. When I go out and get online in Starbuck's or elsewhere all the push notifications work. I have made a through research, obviously it has to do with a setting on my router. Just practically tried every tip and trick I just can't seem to work it out. I have been advised to open port 5223, enable DMZ for the specific IP number my iPod gets while on network, played around with various DNS numbers on my iPod, made sure I am not on any kind of DNS proxy, I even disabled my firewall from the router to see if it will work. No chance! I only have the mobileme push notification working while I am on my home network. My Router has its latest firmware as well. Aztech technical support has no idea what to do. Neither does Apple support. Checked and googled like crazy for over a week now, no answers on the net that I can find. If anyone can help me find a solution to this I would appreciate it very much! I do not want to buy another modem router as I have just recently bought this one.

    Thank you in advance
     
  2. SuBGirL macrumors newbie

    Joined:
    Feb 26, 2010
    #2
    I'm having the exact same problem! I have the same ipod, different router tho, and admittedly i've not tried to get push anywhere other than at home. My boyfriend has an iphone and his push had suddenly become terrible since he moved in with me. After searching all over the net for a solution to my problem i discovered the whole thing about enabling port 5223 and i did it..his notifications are now running like clockwork and i still haven't had a single one! So i know i've enabled the port properly, and done all the turning on and off of notifications to try to jolt them into use, i've even completely wiped my ipod and restored it factory settings and still nothing.

    I looked at the Apple site to see if they could shed any light on it and as usual they were useless. If i find a solution i'll post it here to see if it helps you..could you do the same please? Fingers crossed for both of us.
     
  3. eraysonat thread starter macrumors newbie

    Joined:
    Feb 9, 2010
    #3
    Hello subgirl

    Hey subgirl thanks for your reply. I am really looking forward to it if you find a solution to it. I have done EXACTLY the same things like you did. I have to go to Starbuck's to get the notifications to work :eek:. Well apparently having a router modem integrated is not a very good thing to do. I have just recently talked to my bro a tech nerd, he said to me these integrated devices don't let you do much changes on the settings. I have bought this router modem only 4 months ago. I don't want to throw it and get a modem and router separately now. Apart from that neither the Apple tech support nor the Aztech tech support found a solution to this. I have to mention one funny thing though. There's one push notification that works with my home network and that's for my mobile me account. I have a me.com email address as well so I get notifications for that. But nothing for the rest, yahoo, hotmail all the apps etc.. I am about to give up because you have no idea how many nights and days I have digged the net to find a solution to this. I am still looking so if I find one I will let you know too. P.S It's weird that your boyfriend's are working now. R u sure he is not on his 3G on his iPhone? Bec the push notifications will work on his 3G.

    Thanks again for contacting me
    Looking forward to hearing from you
    Sonat
     
  4. eraysonat thread starter macrumors newbie

    Joined:
    Feb 9, 2010
    #4
    I have some interesting news for you

    Hey subgirl. How funny is the timing of your thread to me. The universe must be working with you :) Well..i have discovered something. I don't live in the US but I have a lot of favorite shows there like SNL. Website called Hulu in the US broadcasts very episode after it has aired. The problem is this website requires a US based ip number to play the videos. Yesterday I bought a US based IP number through a VPN service (Virtual Private Network-proxy server) . Thru my normal ethernet connection without disabling it, I connect to their VPN and I get a US ip number (the trick here is it's thru a proxy server). I finally was able to watch Hulu. I put the same VPN settings into my iPod touch. I get on the wireless at home, then make a connection to the VPN and guess what happens..the push notifications start flying in! WOW! I got so surprised because this was the least I expected. I am on a paid VPN (USD 5 a month) but you don't need that. Hulu doesn't work with free VPN proxies because they have them all blocked for international access. But you can try one of the free VPN programs there's one called hotspotshield. It's a program you download on your imac and when you run it you get on a VPN (proxy server). The issue here is I am not sure if you can get the setting parameters from this program because it is automatic may be if you contact them at www.hotspotshield.com they can give you the parameters and you can set it on your iPod touch VPN settings. Then you will have all the push notifications working I think. Because mine now works flawlessly. How weird is this??? This was my lucky day this week :)
     
  5. whatupg1 macrumors newbie

    Joined:
    Jun 30, 2009
    Location:
    Chicago
    #5
    I live in the US and I was having problems receiving "Push Notification" on my iphone 3G while on my home network (Linksys WRT54G Router with Comcast ISP) and I did some research and in one of the forums someone was having a similar issue and changed their DNS setting for their wifi network on their iphone. So I gave it a try and it worked for me.

    On my iphone I went to Settings>Wi-Fi>My Network>DNS

    I changed my DNS setting to 8.8.8.8 which is the IP Address of Googles DNS Servers check the following link for more details http://code.google.com/speed/public-dns/

    Again I live in the US and this seemed to resolve my "Push Notification" issues
     
  6. eraysonat thread starter macrumors newbie

    Joined:
    Feb 9, 2010
    #6
    Hi whatupg1

    Thanks for your reply. I have already tried that solution, in many different combos of DNS servers including the one you've listed and it didn't work for me. I think iPhone is slightly less problematic compared to iPod Touch when it comes to this issue. They are wired almost the same way but I guess there must be some tiny difference on the way both of these gadgets get on wifi. May be that's why this solution didn't help me get my push notifications work on my iPod Touch. Getting on a proxy thru a VPN service got it worked out. What a complicated way to solve actually a simple issue.
     
  7. BoSox416 macrumors newbie

    Joined:
    Apr 7, 2010
    #7
    Alleluia!!!

    Alleluia!!! This change fixed the problem! After 2 trips to the Genius Bar and scouring the internet, I came across this post and it worked for me! I only hope that changing the DNS settings works for everyone else.
     

Share This Page