Push Notification Will Not Work

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TexasGirl, Dec 23, 2009.

  1. TexasGirl macrumors newbie

    Joined:
    Dec 23, 2009
    #1
    Well, I've been lurking around this site for some time now reading about all kinds of stuff and out a lot of useful information but nothing that can fix my problem. Long story as short as possible, because it is long but I am going to try to tell the important details just in case anyone may need to know them....

    I have an iPhone 3Gs 16 GB 3.1.2 with firmware 05.11.07.

    I got it from the Apple store, jailbroke and unlocked it on November 12th 2009 using blackra1n.com ran the quick jailbreak then opened the blackra1n app, and ran blacksn0w. It has worked PERFECT NO FLAWS AT ALL till last night.
    :(

    I have never downloaded a 3rd party app or Cydia for that matter, after I jailbroke the phone. I just used the jailbreak to use the phone on T-Mobile network. Like I said, it has been working perfect nothing wrong at all. Last night however I read about an app on Cydia called "Backgrounder". I thought it would be helpful so I went against my promise to myself and downloaded Cydia, found "Backgrounder" and downloaded it. When it finished it said reboot phone. I told the phone to reboot and here is where my nightmare begins....

    1st, the phone turned on but then all the sudden turned itself off. It would only show the little apple then turn off. My iTunes would not recognize there was a phone connected to it and after a few hours I finally found, I think on this site, to hold the "home" and "off/on" button at the same time while plugging it into iTunes then let iTunes see it, and restore it.

    So now it's restored. I went back on blackra1n.com and rejailbroke my iPhone, got almost everything up and running except my YouTube and Push Notifications! I Googled and Googled and YouTubed help search for almost 24 hours now I cannot figure out how to get them turned back on. Under
    settings>notifications, it is turned on but my push apps and YouTube will not work.

    All I found in my hours of searching was to reinstall Cydia (which I did not want to do again) and then go to
    manage>sources>edit>add... type in htt://cydia.iphoneil.net >add source > done > go in to iPhoneil.net and download Push & YouTube Fix and so everything I've read says this should work. IT DOES NOT WORK. While this app "Push & YouTube Fix" doesn't even begin to download but instead has a pop up telling me "http://ctdya.iphoneil.net HTTP:/ 1.1 404 Error Not Found" and the only option it give is "Okay". I tell it "Okay" then a 2nd pop up comes up saying HTTP/1.1 404 Not Found. Again the only option is "Okay". I tap "Okay" and the phone then says "Return to Cydia", and no other option. So nothing is downloaded, and nothing is fixed.

    I'm going nuts here trying to figure out this problem. Can someone PLEASE help me! I've read that the kid that made blackra1n, updated this software that I used from the first time I jailbroke my iPhone so that now it's supposed to be better or something but for me the 1st time I jailbroke the phone using it, it was better I had no problems at all with my phone I could do everything on my phone possible. I’ve already tried and restored it and reunlocked/rejailbroke it twice. It happens right when the phone is unlocked. ( I have for the time being, since I already had Cydia on it and know my problem is happening right after jailbreak, have installed iBlacklist on my phone but the only setting I have “on” is SMS privacy. And I have tried turning that off and my push still does not work. I don’t even have la blackist.)

    Please help!!! :(
     
  2. velour macrumors newbie

    Joined:
    Dec 25, 2009
    #2
    I've got a new iphone on tmobile and have been doing a lot of research on this. Unfortunately, we're all out of luck. The cydia package for the Push & YouTube Fix went down sometime on Dec. 23, and from that point on, no one has been able to download it. I have no info on how temporary that is, but i do assume it'll be back up soon enough -- probably just a link to the files that expired. If i find a workaround, will let you know.
     
  3. TexasGirl thread starter macrumors newbie

    Joined:
    Dec 23, 2009
    #3
    I found this I am going to try it.


    1. Borrow any simcard for iPhone official carrier in your country (i use O2 in UK)
    2. Restrore your iPhone with simcard O2 inserted
    3. When iTunes asks about account setting, create a new account. Don't use backup'ed account
    4. After finish restore, let Apple activates your iPhone and this will register a new certificate into your iPhone
    5. Install IM app (if you use app like Ping! or BuzzMe, you need to DELETE your ID and create a new one because Ping!/BuzzMe servers have registered your old certificate for your old ID, not the new one (Yes, you have to sacrifice deleting it)
    6. Use your unallowed simcard and unlock like normal (Don't forget to return the O2 simcard to your friend
    7. Done! happy pushing!
     
  4. TexasGirl thread starter macrumors newbie

    Joined:
    Dec 23, 2009
    #4
    IF YOU ARE IN THE USA AND USING AN IPHONE ON ANY OTHER NETWORK BESIDES ATT DO NOT NOT NOT PUT http://apt.macosmovil.com/ INTO CYDIA. ITS MAKING MY PHONE THINK ITS FROM SOME OTHER COUNTRY AND WILL NOT OPEN MY APPLE APP STORE FOR THE US!
     
  5. TexasGirl thread starter macrumors newbie

    Joined:
    Dec 23, 2009

Share This Page