Push notifications for whatsapp stopped with beta 4 and 5. help with logs

Discussion in 'iOS 7' started by mirzank, Aug 7, 2013.

  1. mirzank macrumors regular

    Joined:
    Apr 15, 2008
    #1
    so my whatsapp push notifications stopped with beta 4. and havent been fixed with beta 5. all my other push services work fine. not a single issue.

    i opened up the log file, and heres what i found in the Console section when i open the log file:

    Under the "System log queries - all messages" these two results for push:



    Code:
    2013-08-07 4:54:27.645 PM apsd[319]: Unable to bootstrap_lookup connection port for 'com.apple.ubd.system-push': Unknown service name
    
    2013-08-07 5:59:44.581 PM mDNSResponder[59]:  21: DNSServiceGetAddrInfo      v4v6 22-courier.push.apple.com. PID[-1]()
    and under Files - whatsapp-2013-08-05 the following (again, sane log file i opened in console):

    Code:
    2013-08-05 17:13:02.747 WhatsApp[2223:707] LL_A* -[WhatsAppAppDelegate application:didRegisterForRemoteNotificationsWithDeviceToken:] [Line 1488] push-token/success [<4b9cd63c 69b30d75 7d7fc724 ac9f30b7 b6c23809 14302491 e0c71f7c e14a3494>]
    2013-08-05 17:13:13.356 WhatsApp[2223:4c03] LL_N  -[XMPPConnection logStanza:recv:] [Line 3180] connection/stanza/send/iq id='1375704783-5' to='s.whatsapp.net' type='set' req='push-config'
    2013-08-05 17:13:13.716 WhatsApp[2223:4c03] LL_N  -[XMPPConnection logStanza:recv:] [Line 3180] connection/stanza/recv/iq id='1375704783-5' from='s.whatsapp.net' type='result' req='push-config'
    what does this mean? these are the only occurrences of the search term "push" in the log file in console.

    can someone see whats going on?
     
  2. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #2
    Why are you posting this here? Don't you think the developers of Whatsapp should have this info?
    I just mean that we don't have access to check to see why the tokens show success and you don't receive a push notice. Only the developers do.
     
  3. mirzank thread starter macrumors regular

    Joined:
    Apr 15, 2008
    #3
    Poting this here like i said for help. Some crowd sourced helped with someone that understands how push works.

    I emailed whatsapp. They gave me a canned response that they dont support beta software.

    So im trying to figure out with some help where the problem lies so i can either hold on hope that it will get fixed, or pester the right people to fix it..
     
  4. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    Either way there is no hope anyone here can help. It's not a problem with iOS 7, but with a third party app. They are the only ones who can change things. There is no way someone here can fix it.
     
  5. mirzank thread starter macrumors regular

    Joined:
    Apr 15, 2008
    #5
    Yes i know people here cant fix the issue. I said help me find what abd where the issue is. It seems like a very rate bug i have. I have been in that boat before with ios where ive been stuck with a not fixed rare bug for ages.

    Push is a big issue. I would have ezpected it to be fixed in b5. It hasnt. So if someone could pinpoint where the issue is, help me get closer to the root, i can then file the appropriate bug reports and send emails to get someone from whatsapp or apple to look into it.
     
  6. hamiltonDSi macrumors 65816

    hamiltonDSi

    Joined:
    Jul 29, 2012
    Location:
    Romania
    #6
    Have you tried reinstalling WhatsApp ?
    BTW, I use WhatsApp daily and I do not have this problem.
     
  7. nalk7 macrumors regular

    Joined:
    Jul 11, 2008
    #7
    I don't have this problem either, as stated before, try reinstalling.

    Cheers
     
  8. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #8
    Perhaps the developers of WhatsApp are already aware of the issue. Perhaps they have even already fixed it. But, because you cannot submit any app updates for iOS 7 to the App Store yet, they are not able to push out a fix. You need to be patient and wait until iOS 7 is officially released.
     
  9. mirzank thread starter macrumors regular

    Joined:
    Apr 15, 2008
    #9
    yep seems to be the best way to go for now. i'm just a rare group thats having this issue. very very rare. no other apps having problems. and a restore of the OS, reinstalling app, resetting network settings and all settings didnt do anything, so i wanted to see if anyting fishy was going on.

    lets hope an app update and official os 7 releases fixes it.
     

Share This Page