PvZ crash...JB related?

Discussion in 'Jailbreaks and iOS Hacks' started by murdercitydevil, Aug 15, 2010.

  1. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #1
    I'm not sure if this is related to Jailbreaking, but as far as I know, all evidence points to it being the case. I recently fired up Plants vs Zombies after not playing it for a while, and it turns out it will no longer launch. It goes to the popcap loading screen, then just closes. Some people on macthemes say they have similar problems with popcap games.

    I'm pretty sure this only started happening after i jailbroke, but maybe something else broke this game? Installing/reinstalling the app didn't fix anything. Just wondering if anyone has a solution, or at the very least, a similar experience. Thanks.
     
  2. Rob Mclovin macrumors 6502

    Joined:
    Jul 24, 2008
    #2
    If you ever wanna see if a app is crashing due to jailbreak, put your iPhone in safemode then try the app. I remember this was the case with monkey ball 2, but PvZ had an update for crashing.
     
  3. murdercitydevil thread starter macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #3
    Yep, definitely JB related. Works fine in safe mode. But how does one pinpoint the exact cause?
     
  4. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #4
    Do you have any themes applied?
     
  5. murdercitydevil thread starter macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #5
    I do indeed. And if I understand what you're implying, then...


    Yes, it turns out PvZ crashes when a winterboard theme is applied. Great.
     
  6. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #6
    Ive read its been happening with other themes. Some apps crash with themes. Its a weird problem lol.
     
  7. theman510 macrumors 6502

    Joined:
    May 13, 2009
    Location:
    New Jersey
    #7
    Any known workaround for this yet? I have a theme and like the OP, can't get past the pop-cap loading screen. VERY annoying!! :mad:
     
  8. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #8
    i got PvZ on one iPhone 3Gs (iOS4) and iP4 both JBed and it runs smooth on both.
     
  9. theman510 macrumors 6502

    Joined:
    May 13, 2009
    Location:
    New Jersey
    #9
    Are you using a theme?
     
  10. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #10
    Got winterboard and a theme on the 3GS yes..(iP4 is not)
     
  11. CooKieMoNs7eR macrumors 68000

    CooKieMoNs7eR

    Joined:
    Nov 18, 2009
    #11
    I know how to get PvZ to work, all you have to do is download an older version of it, if you download the latest version of the app than it's going to crash, I had this problem and that's how I got it to work again no matter what theme you have on...hopefully this helps.
     
  12. theman510 macrumors 6502

    Joined:
    May 13, 2009
    Location:
    New Jersey
    #12
    I've tried with earlier versions. However with those, the popcap screen comes up for about half a second then the whole screen goes black and nothing ever happens. i have to click the home button for it to quit
     
  13. CooKieMoNs7eR macrumors 68000

    CooKieMoNs7eR

    Joined:
    Nov 18, 2009
    #13
    Mine works fine, 1.3 is out so that didn't work for me, I downloaded 1.2 and it works.
     
  14. theman510 macrumors 6502

    Joined:
    May 13, 2009
    Location:
    New Jersey
    #14
    well i took off my glaskart theme and that seemed to do it for me. game is working now. too bad, i loved the way that theme looked
     
  15. Claude626 macrumors 6502

    Joined:
    Jun 21, 2010
    #15
    I think the culprit are themes that affect the PvZ icon.
     
  16. alphapanda macrumors newbie

    Joined:
    Sep 5, 2010
    #16
    YES finally, I got it working. Thank you claude626! The problem was indeed related to pvz icon.
     
  17. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #17
    is not due to being jb, more like an icon change of it when using a theme or something or a jb app you downloaded....
     

Share This Page