PwnageTool 4.1 Freeze Problem

Discussion in 'Jailbreaks and iOS Hacks' started by Kepesk, Oct 21, 2010.

  1. Kepesk macrumors member

    Joined:
    Jul 15, 2008
    #1
    I'm having a problem using PwnageTool 4.1 to put my iPhone 3GS into DFU mode. Whenever I try, I make it to the final "Hold Home Button for 10 Seconds" screen and then the count freezes when it hits 6 or 7. I try to keep holding my home button till second 10, but then my phone just reboots like normal.

    Of course, trying to restore when I set it to DFU mode myself just returns error 1600.

    I've tried redownloading the firmware, rebuilding it with PwnageTool, and reinstalling PwnageTool to no avail. There isn't even anything bad in the log. Before anyone asks, I tried the ~/Library/iTunes/"Device Support" thing too, and I even tried putting my phone on a powered USB hub. No change.

    I searched Google, but the only people I found who claim to have a solution were talking jibberish. English is clearly not their first language.

    So I put it to you, the good folks of the MacRumors forums. Surely someone out there can suggest a solution?

    Thanks in advance!
     
  2. gatearray macrumors 65816

    Joined:
    Apr 24, 2010
    #2
    I'm having the same exact issue, the counter stops at 6 or 7, then the phone reboots as normal.

    iPhone 4 using Pwnage Tool 4.1.1 on OSX 10.5.8, PPC G5
     
  3. Lionheart macrumors regular

    Lionheart

    Joined:
    Jun 29, 2007
    Location:
    Tampa, FL
    #3
    Just keep holding it until iTunes pops up a message saying you're in DFU mode. Worked for me. Took about another 6-8 secs.
     
  4. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #4
    From iphone_dev
    Retweeted by MuscleNerd

    PwnageTool 4.1.1 http://is.gd/g9PDf should fix any issues OSX 10.5.x users were seeing (no need to re-run it otherwise!)

    S-
     
  5. gatearray macrumors 65816

    Joined:
    Apr 24, 2010
    #5
    Thanks for the help.

    So, you had iTunes running while in PT doing the DFU mode? From what I read, it seemed iTunes was supposed to launch after PT did it's thing.

    Also, when I did what you said (with iTunes running) the counter still stopped at 6 secs, but iTunes showed a phone in DFU mode for a moment, I then let go of the home button, and my phone still restarted with the Apple logo, etc. as normal.

    So, still no luck, darn it...
     
  6. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #6
    download the updated Pwnage Tool 4.1.1 and it should work now...
     
  7. gatearray macrumors 65816

    Joined:
    Apr 24, 2010
    #7
    Appreciate it, but I am using 4.1.1 and just downloaded it this afternoon for the first time. Got it from the mirrors, tried two of the three current ones listed, they are all 4.1.1...

    I couldn't get the torrent to go, the tracker gives me an error that it 'can't connect to host'. Do you think there might be something fishy about those mirrors? I'm stumped!

    Thanks
     
  8. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #8
    check the hash for them, it should be SHA1 Sum = 385c55b59d49fa6f24b4bdf7b679483d9e2fc5da

    any #'s besides those then they are fishy. If you are getting it to reboot while doing the DFU it means that you are probably doing something wrong while doing the procedure. Follow the instructions and the sounds for you to proceed to the next steps not necessarily the exact seconds that appear on screen.
     
  9. jaylay0707 macrumors member

    Joined:
    Jun 29, 2008
    Location:
    the LBC
    #9
    I'm not sure if you solved the problem yet, but I had the same exact issue. I found out that it was because I was running Pwnagetool on a PPC computer. Ran it on my buddy's Intel Mac, and it worked :)
     
  10. gadgethacker macrumors newbie

    Joined:
    Jun 28, 2009
    #10
    Working method

    This "special DFU mode" has many problems, so you have to get the error first, then try using pwnagetool to go to DFU again, but this needs many tries, but I got it to work.

    This was how I got it to work,

    In my mind, I think: QUICK, so you have to do this precisely

    1. NO NEED FOR NEW CUSTOM FIRMWARE
    2. Open up Pwnagetool
    3. Click on Expert Mode
    4. Click on the phone/ device you have
    5. Click on DFU
    6. Follow DFU steps
    7. On last step, when you get stuck on 6 it will show Successful
    8. Keep home button held down for another 10 seconds
    9. Press OK on the blue popup, but don't quit Pwnagetool
    10. THE NEXT STEP IS CRUCIAL, MUST DO IT QUICK
    11. Hold down Option and then click on Restore
    12. Choose your firmware
    13. If verifying takes a little long, and you see preparing for iphone's progess bars stutter a little, you are successful, then there would be a white screen on your phone
    14. Restore would begin
     
  11. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #11
    Not sure why you are having to go through this process. I ran it normally with Itunes closed. When pwnage put the phone in DFU successfully I closed pwnage tool and then opened itunes. Worked a charm.
     
  12. sucksathacking macrumors newbie

    Joined:
    Jan 22, 2012
    #12
    I know this is late to the party, but I too have encountered the exact same issue as OP on a PPC (non-Intel based) mac. It's probably too much to ask if anyone's found a solution to this problem since then, but if someone knows offhand, please post.

    For now I'm probably just giving up (until I can find access to a better computer). Spent my whole **** weekend on thus just to change that stupid SMS sound.
     

Share This Page