Python 2.6 Compilation Errors on OS X 10.6

Discussion in 'Mac Programming' started by ShiggyMiyamoto, Aug 30, 2009.

  1. ShiggyMiyamoto macrumors 6502a

    ShiggyMiyamoto

    Joined:
    Mar 29, 2004
    Location:
    Just outside Boston, MA.
    #1
    Hey all. I don't know where else to post this, so if need be, move it to the proper forum. I'm trying to install XChat 2 via Mac Ports on OS X 10.6 Snow Leopard (final) and here's the error I get:

    Code:
    sudo port install xchat2
    --->  Computing dependencies for xchat2
    --->  Building python26
    Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/Python-2.6.2" && /usr/bin/make all MAKE="/usr/bin/make CC=/usr/bin/gcc-4.2" " returned error 2
    Command output: /usr/bin/gcc-4.2 -L/opt/local/lib -u _PyMac_Error Python.framework/Versions/2.6/Python -o python.exe \
    			Modules/python.o \
    			 -ldl      
    ld: warning: in Python.framework/Versions/2.6/Python, file is not of required architecture
    Undefined symbols:
      "_PyMac_Error", referenced from:
      "_Py_Main", referenced from:
          _main in python.o
    ld: symbol(s) not found
    collect2: ld returned 1 exit status
    make: *** [python.exe] Error 1
    
    Error: The following dependencies failed to build: gtk2 atk gtk-doc gnome-doc-utils py26-libxml2 python26 rarian getopt intltool gnome-common p5-getopt-long p5-pathtools p5-scalar-list-utils cairo libpixman libpng jasper jpeg pango shared-mime-info tiff xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto
    Error: Status 1 encountered during processing. 
    Does anyone know why Python 2.6 won't build on Snow Leopard? I mean I know the OS just released, but what's stopping it from compiling properly? I can't get past the install process unless that compiles apparently...

    Thanks,
    ShiggyMiyamoto
     
  2. Blo0dyhellz macrumors newbie

    Joined:
    Sep 9, 2009
    Location:
    Miami
    #2
    You should just back up everything and re-install snow leopard. Same happened to me and it worked just fine after re-instalation.
     
  3. electroshock macrumors 6502a

    electroshock

    Joined:
    Sep 7, 2009
    #3
    Known problem. It's related to the fact that architecture was previously i386 but with Snow Leopard, gcc is now using x86_64, and that's confusing things.

    There is already a patch for it in Python 2.6, but the Python people have not yet released an updated version (probably 2.6.3) that includes the patch. So will have to wait until that comes out, then MacPorts can update their python26 port, then you can update, then retry.

    The Python bug report for this issue:

    http://bugs.python.org/issue6802

    Note: I think this was more of a problem for people with libs built pre-Snow Leopard and trying to mix it with linking done under Snow Leopard. A suggested workaround was to save output of 'port list installed' then remove all ports, ensure the base MacPorts was at least version 1.8.0, then reinstall each of the previously installed ports to ensure all were built and linked under Snow Leopard. Tried that but didn't work for me for things that depended on python26. So, not sure.
     
  4. ShiggyMiyamoto thread starter macrumors 6502a

    ShiggyMiyamoto

    Joined:
    Mar 29, 2004
    Location:
    Just outside Boston, MA.
    #4
    Okay well, I've had XChat 2 running for a while now.... Sorry I didn't say anything sooner.

    For one of the errors I edited a script, and then for the other I deleted a file it was complaining about, and then gmake must have recreated it and it became valid, because the python26 compilation actually completed and was installed properly.

    Thanks for your reply nonetheless!
     
  5. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #5
    Not much constructive to add but I have run into this problem quite a bit over the last few days. I just managed to finish up rebuilding most of my tools (libpcre, Mercurial, Lighttpd, etc) as universal binaries so I'm hoping that should stave off future problems.
     
  6. electroshock macrumors 6502a

    electroshock

    Joined:
    Sep 7, 2009
    #6
    No worries. I had this issue on September 6th, but when I tried again just now (the 14th), no more issues -- and looks like they updated python26 during that time. So now my 9 dependent ports now build and link successfully. Whoo!
     

Share This Page