Python's tkAqua is broken by 10.6 upgrade, how do I fix it?

Discussion in 'Mac Programming' started by bollweevil, Sep 27, 2009.

  1. bollweevil macrumors 6502

    Joined:
    Feb 1, 2008
    #1
    I just upgraded from Mac OS X 10.5 to 10.6, and now "Python quit unexpectedly" every time I execute certain functions. The error printed to the terminal says:

    Tk_MacOSXSetupTkNotifier: first [load] of TkAqua has to occur in the main thread!

    Anybody know how I can fix this? I really don't want to change my Python version right now, I am using Python 2.5 (r25:51918). Thanks.
     
  2. bollweevil thread starter macrumors 6502

    Joined:
    Feb 1, 2008
  3. pnelis macrumors newbie

    Joined:
    Dec 7, 2009
    #3
    Solved it...?

    Sorry, no help, but I have exactly the same problem and wondered if and how you might have solved it in the mean time?

    Thanks a lot.

    Piet Nelis
    The Netherlands
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    The error Python is giving you suggests to me that Python isn't broken, but rather the program you're writing in it is. Tcl/Tk doesn't like being initialized from threads other than the main one... if you try (for instance, the first GUI window your program creates is to display a progress bar for some long task, and the task is entirely self-contained in a thread) you'll get that error.
     

Share This Page