Q: Continual problems with Preview not staying default application

Discussion in 'macOS High Sierra (10.13)' started by likethatonestoplight, Mar 7, 2018.

  1. likethatonestoplight macrumors newbie

    Joined:
    Mar 7, 2018
    #1
    If anyone can help fix this for me, you'll be my favorite person ever. Glad to provide log files or whatever else if you instruct me how.

    I'm running High Sierra version 10.13.3 (17D102), and am on a Macbook Pro Retina 15", late 2013 (MacBookPro11,3).

    My problem started a while ago, when I was still on OSX El Capitan - I'm on High Sierra now. I can't pinpoint exactly when it started, but it's definitely been months.

    The problem is that Preview refuses to remain the default application for PDFs, JPGs, PNGs, basically any file that I've set Preview to open, it won't stay the default. Literally randomly, it will revert back to some other program. Then I will set it back to Preview (Right click -> Get Info -> Open with -> Other -> Click Preview -> Add -> Change All), and for a little while, it will stay opening in Preview -- but literally always, it will revert back to defaulting to some other program. Right now, PDFs keep going to default open in ColorSync Utility and image files (PNG, JPG etc.) keep defaulting to open in Grab.

    I have not been having this problem with any other default file association program. None other than Preview. If I set VLC as the default player for MP4 files, it stays that way until I change it.

    When this started, I had Adobe Acrobat on my system, which I uninstalled in the hopes that this problem would resolve, but it did nothing -- now, PDFs just default to ColorSync Utility, a program I've never used. But yes, it used to keep making PDFs default to Adobe programs, and now it's ColorSync Utility. And I work with PDFs a LOT, so this has basically made me crazy.

    Image files (JPGs, GIFs, PNGs, etc.) keep defaulting to Grab. I go and manually "Change All" to Preview again and again, but it's the same as with PDFs. Preview will simply not stay the default application for these files.

    No, I do not notice any rhyme or reason to the timing of when the default file association changes. It's not when I reboot, the laptop sleeps, or anything in particular. The timing is not regular. Sometimes it'll be under an hour; sometimes several hours; sometimes I'll get lucky and get like a day or so of formerly normal behavior.

    I had El Capitan when this started, but someone suggested it could have to do with not updating to the latest OS, so I updated to High Sierra. Problem remains. I've even reinstalled the entire OS on support's suggestion. That didn't work either. Problem remains.

    Rebuilding LaunchServices in Terminal:

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain u -domain s -domain l -v​

    ... worked, but only temporarily: it did make JPGs and PDFs etc. go back to default Preview, but then the problem will return, over and over again. And when I do this "rebuild LaunchServices" thing, it makes a bunch of the icons/images/whatever you call them (the little 2 photos thing that indicates Preview, etc.) go away until you reboot. I didn't even care about that, if it would have solved my actual problem!

    Basically, I've tried everything I can think of and everything support or anyone has been able to tell me so far, so please help if you have any insight!

    The Preview version I have, if it matters, is "Version 10.0 (944.4)."




    Processor Name: Intel Core i7
    Processor Speed: 2.6 GHz
    Number of Processors: 1
    Total Number of Cores: 4
    L2 Cache (per Core): 256 KB
    L3 Cache: 6 MB
    Memory: 16 GB

    Untitled:
    Available: 24.2 GB (24,195,522,560 bytes)
    Capacity: 450.01 GB (450,013,147,136 bytes)



    Glad to provide any other info if it might help. Very grateful for any help anyone can provide. Thanks!
     
  2. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    not sure what's happening, but the fact that it happened thru a new OS install suggests that the problem is with your account. try making a 'test' admin account, copying some pdfs, images onto that desktop, and see if the problem persists. if so, it's a global issue, but if not... it's something in your home folder.. in which case check there for acrobat files (in the app support folder in your user library for example).

    anyway, i'd start with a test account....
     
  3. likethatonestoplight thread starter macrumors newbie

    Joined:
    Mar 7, 2018
    #3
    Thanks for your response.

    I don't have any Adobe programs except for Adobe Digital Editions (the program that lets you read eBooks from library "checkouts" and such). I have old a really old Photoshop and other Adobe programs on an old backup of a former Macbook, but those aren't in my Applications folder nor do I ever use them. It's literally just a backup of the entire hard drive of that old Macbook. So the only Adobe applications I actually have are Adobe Digital Editions. Should I uninstall that too?

    It's been like whack-a-mole -- every time I delete/uninstall whatever program PDFs and other files keep defaulting to instead of Preview, it just jumps to another program. The order it's been for PDFs has been:

    Adobe Acrobat Reader DC (uninstalled) --> Adobe Acrobat Pro (uninstalled) --> Adobe Digital Editions (not yet uninstalled) --> ColorSync Utility

    For image files (JPG, PNG, etc.), it's just been defaulting to Grab.

    I've attached screenshots of the app support folder in my user library -- what do you think I should do, just completely delete the "Adobe" folder in Application Support?

    Thanks again!
     
  4. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    test account. copy some pdfs, jpgs, pngs, to either an external drive or into a folder on the main level of your hard drive. go into system preferences, go to Users & Groups; click the '+' button and create a 'test' admin account (something simply named, simple password). reboot, sign into that account, open those pdfs, jpgs. do they open in preview? or do the 'change all' thing, see what happens.

    if the problem persists, it's something to do with the app, or the OS. but if it works... the problem's somewhere in your user folder (prob in the user library). for example, you could delete the com.apple.Preview.plist and com.apple.launchservices files (or just move them to the desktop, in case you want to restore them). remove them with the apps closed...

    and consider calling apple, or getting to an apple store if the problem persists...
     
  5. NoBoMac macrumors 68020

    Joined:
    Jul 1, 2014
    #5
    Might not be Adobe: could be some other program running on the machine, even if just occasionally, that is resetting the LaunchServices each time program is launched (i.e. akin to some browsers having "always check/make default" option, just doing it for filetype associations). So, MAYBE something akin to camera import software, alternative media viewers/players, etc. MAYBE even VMware/Parallels: might be something with their assigning Windows apps to launch and visa-versa when running in their "unified" modes?

    Some folks are reporting similar issues, but pointing to Firefox being the cause.
     
  6. likethatonestoplight thread starter macrumors newbie

    Joined:
    Mar 7, 2018
    #6
    Really? I do use Firefox on my Mac; it's my default web browser. I also use Safari and Chrome at times for certain things that they seem to handle better, but I'm desperate enough that I would stop using Firefox if I absolutely had to, to fix this problem.

    Do you have any more details about why / how Firefox is doing this and what might fix the issue? Thanks so much.
    --- Post Merged, Mar 7, 2018 ---
    Okay, will try this, thanks. But the thing is, it takes a while to see if the default switches to some other program instead of Preview. It won't happen instantaneously, probably, when I open the test account. If I set the default to Preview, it will stay that way for a little while, but then randomly at some point will change to ColorSync Utility or whatever. Thanks again for the info!
     
  7. NoBoMac macrumors 68020

    Joined:
    Jul 1, 2014
    #7
    Re: Firefox: There are some threads on Apple's discussion boards on the subject. No real details other than they were only seeing it with Firefox Quantum. Once they stopped using it, things settled down for them. Guessing maybe something with default applications that are defined within Firefox settings.
     
  8. likethatonestoplight thread starter macrumors newbie

    Joined:
    Mar 7, 2018
    #8
    Thanks for the info. I've scanned the Apple discussion boards but never found my exact problem. Have you seen anything where Firefox Quantum is causing the problem I described (Preview [or another program] not staying the default for opening certain file types)? I've seen people complaining about Quantum being slow, causing other problems, crashing, etc., but not causing this issue. Would just like to see if anyone has. Thanks again!
     

Share This Page

7 March 7, 2018