Qmaster+MP+additional machines? Worth the hassle?

Discussion in 'Digital Video' started by Macinposh, Sep 1, 2009.

  1. Macinposh macrumors 6502a

    Joined:
    Jun 7, 2006
    Location:
    Kreplakistan
    #1
    So,tried to study the qmaster a bit.

    I have a FCP3+ MP and a MB5.1 and decided to try to add the macbook as a extra "render farm" to help with processing with compressor. Uuh,had a intresting evening...

    So MP -> MB via ethernet cable.MP as the boss.


    First try : In short,I think I managed to engage the processors/in out in the MB with the "quickcluster with services" setting but didnt notice that much improvement in the speeds. about 100-130% core utilisation.

    Next tries were when I put the MB to "service only". Meh,the compressor started more slowly,did not allocate any processing to the mb all the time or ever and in general the processing times were the same.

    After few tries I quit but boom! the processors hit 400% on the MP. even if I quit all the qmasters+admins+compressors. And I couldnt kill the processes from the activity monitors either!!! I killed one process but it came instanly back.
    So I had a constant,steady 400% proz utilization and nothing was happening...



    So,in short : Is it worth to even try?
    I mean,is there even a theoretical change to speed up the compressors/renders?
    Is it theoretically possible with my setup?
    Is it economically (timewise) to even try to setup anything,or is the Qmaster that kind of P.O.S that people seem to think it is?



    Cheers!
     
  2. matteusclement macrumors 65816

    matteusclement

    Joined:
    Jan 26, 2008
    Location:
    victoria
    #2
    did you set up each device to have it's maximum "instances"?
    sys pref>apple qmaster

    how many cores does each machine have?

    My experience has been this:
    intel imac with 2 cores
    MBP 1st gen with 2 cores

    I set the imac with 2 instances and the MBP with 1 and I get a speed bump.
    The reason (i am guessing) is because my MBP has duo core while the imac has duo2core. if I set both to 2 instances, I am waiting on the MBP.

    have you tried the MP as just a quick cluster and leave out the MBP?
    Do you know about reseting your clusters holding the option key while in :
    sys pref>apple qmaster
    resetting and setting up your cluster might get your render farm working. I think it's worth it.
     
  3. SimonMW macrumors 6502

    Joined:
    Jan 15, 2008
    #3
    Don't forget RAM. Qmaster clusters need a lot of RAM to work with.
     

Share This Page