Qt install

Discussion in 'Mac Programming' started by toddburch, May 1, 2008.

  1. toddburch macrumors 6502a

    Dec 4, 2006
    Katy, Texas
    I downloaded QT some time ago and now I'm trying to install it. 4.3.3.

    I've just installed it, but in Terminal, I'm confused on the permissions I saw.

    I share this computer with my son (Kevin). I used my account to install it. However, in Terminal, I did an "ls -l" in /usr/include/qtuitools and it shows this:

    todd-burchs-computer:/usr/include/qtuitools toddburch$ ls -l
    total 24
    -rw-r--r--   1 Kevin  wheel    23 Dec  4 15:58 QUiLoader
    -rw-r--r--   1 Kevin  wheel    23 Dec  4 15:58 QtUiTools
    -rw-r--r--   1 Kevin  wheel  2979 Dec  4 15:58 quiloader.h
    todd-burchs-computer:/usr/include/qtuitools toddburch$ 
    Why would it show Kevin here as the owner and not me? And what the heck is "wheel"? I issued the SET command and USER=toddburch is set.

    Second question.

    I would prefer to use Xcode for development with QT. However, the QT doc seems to be lacking a bit for this old timer. And, Xcode is not too friendly either.

    In Terminal, I created a new directory called "qtcode" and CD'ed into it. With no other files in the folder, I ran "qmake -project". That created qtcode.pro. Then, I ran "qmake" with no parms. That created qtcode.xcodeproj. Seemingly, so far, so good.

    Then, I go into Xcode and File->Open the project. It's empty. Now, I'm stuck. What's the right process to add a C++ file? I tried File -> New File -> BSD -> C++ file. I called it qtcode.cpp, and did not check for a header file. The default directory present for the file create was fine for my project (the qtcode folder). I clicked OK and got the empty qtcode.cpp member, pasted my code and, and then nothing. The Build button was greyed out and I could not compile. What step did I miss? What else do I need to do?

    Thanks, Todd
  2. yeroen macrumors 6502a


    Mar 8, 2007
    Cambridge, MA
    1. The 'wheel' group comes from BSD. On BSD, it's the group of users who can 'su' to the root account. On OS X, the semantics of this may or may not be the same, but it's nothing to worry about. The /usr, /sbin/, /dev, and other system directories have 'wheel' group ownership. As for the 'Kevin' ownership of the Qt files, I had the same problem with the Qt installation. It installed itself with the other administrator account ownership, not my own ( a bug in Qt's install script? A common misconfiguration?).
    Just chmod -R username:groupname at the top Qt directory to set it to whatever user/group combo you want.

    2. Instead of Xcode, just use Qt Designer ($QTDIR/Designer.app). It's Qt's graphical IDE and GUI builder. Generally, I'm not an IDE kind of guy (vim/emacs/terminal for me), but I do use Qt Designer.
  3. toddburch thread starter macrumors 6502a

    Dec 4, 2006
    Katy, Texas
    Thanks so much. (I've been busy or would have replied earlier.

    I will do the chmod commands. Looks like QT gets spread all over tar-nation though.

    I will also take a peek at Qt Designer. I've been running some of the demo programs and Qt looks pretty robust.

    Thanks again!


Share This Page