qtweeter

Discussion in 'Jailbreaks and iOS Hacks' started by nickrinaldi, Feb 17, 2011.

  1. nickrinaldi macrumors regular

    Joined:
    Jul 21, 2009
    #1
    for those that used this, updated to work on 4.2.1, sorry if this is already old news.
     
  2. enklined macrumors 6502

    Joined:
    Sep 13, 2007
    Location:
    Sacramento
    #2
    I can confirm that the newest qtweeter update, 3.66, runs on 4.2.1. :)
     
  3. johnnyxhuynh macrumors regular

    johnnyxhuynh

    Joined:
    Jun 17, 2006
    Location:
    Houston, TX, USA
    #3
    The only two packages (both version 3.66) I found for qTweeter were from the insanelyi and xSellize repos. Neither package would connect to Twitter for me -- kept getting Twitter (null) in the list of accounts connected that would clear itself upon restart of the app.

    Is qTweeter available on any other repos? Thanks!

    P.S. Couldn't find it on ModMyi as indicated here:
    http://modmyi.com/cydia/package.php?id=19948
     
  4. Zman3001 macrumors member

    Joined:
    Sep 30, 2008
    #4
    Any update on this? I am having the same problems connecting to twitter, I am running 4.3.1 on an iPod Touch 4g. Thanks in advance.
     
  5. DirtySocks85 macrumors 65816

    DirtySocks85

    Joined:
    Mar 12, 2009
    Location:
    Wichita, KS
    #5
    Well I just now found out from this thread (almost 2 months later), after the last qtweeter incompatibility sent my phone into a constant reboot loop and caused me to restore 3 times before figuring it out (along with a handful of other pkgbackup and greenp0ison nightmares), I had avoided it until I heard there was a solid fix. Thanks for the info.
     
  6. Zman3001 macrumors member

    Joined:
    Sep 30, 2008
    #6
    Now that the app is back, I tried it again since the developer said that it has now been tested on 4.3.1. It still gives me the same error: "kept getting Twitter (null) in the list of accounts connected that would clear itself upon restart of the app."

    I type in my info for twitter registration to add my account, and after I push allow it quickly flashes the app allowed page but then quickly goes into a blank 404 page, and then that disappears and it says the account is ready but it calls it twitter-null instead of my twitter handle. It says in my account settings that I gave it access, but nothing. My facebook account works fine though.

    Anyone have any ideas? I really want to give this developer my money, but I won't pay for a non-working app.
     
  7. johnnyxhuynh macrumors regular

    johnnyxhuynh

    Joined:
    Jun 17, 2006
    Location:
    Houston, TX, USA
    #7
    I am getting the "null" error as well. Very disappointing. Will try to contact the developer directly to see if I can get some feedback.
     
  8. Sachz macrumors newbie

    Joined:
    Jul 12, 2009
    #8
    Possible fix

    After refusing to put up with the alternatives (TweetDeck, Seemsic, etc.) after getting used to the ease of use qTweeter brings, I started to experiment.

    It seems that on other accounts that don't have HTTPS enabled, qTweeter works fine. On the particular (HTTPS enabled) account that is giving me trouble, Twitter.com gives me an error when trying to change the setting.

    Can anyone else confirm? Like I said, it works on my other non-https accounts just fine.
     
  9. Mackinch macrumors newbie

    Joined:
    Oct 30, 2009
    Location:
    South East England, UK
    #9
    Yes, you are correct. My non https account works fine. My https account does not and i get the (null) issue.
    However when i now try to turn off https in twitter is comes back with the "something is technically wrong" error message
     
  10. Zman3001, Apr 24, 2011
    Last edited: Apr 24, 2011

    Zman3001 macrumors member

    Joined:
    Sep 30, 2008
    #10
    I guess this means that qtweeter is not compatible with https. And since the developers have stopped supporting qtweeter or just say "hmm looking into it" and never really do, this means that the app will always be problematic.

    But feel free to bug one of the developers about it until he fixes it, his twitter name is @TheAfricanNerd.
     
  11. johnnyxhuynh macrumors regular

    johnnyxhuynh

    Joined:
    Jun 17, 2006
    Location:
    Houston, TX, USA
    #11
    Unfortunately, I am also getting the "Something is technically wrong" error message when trying to turn off "Always use HTTPS" in Twitter Settings. Frustrating!
     
  12. johnnyxhuynh macrumors regular

    johnnyxhuynh

    Joined:
    Jun 17, 2006
    Location:
    Houston, TX, USA
    #12
    According to @TheAfricanNerd's Twitter about me blurb, he's "Doing some cool new stuff at UberMedia", which I guess would make sense if his qTweeter product would potentially compete with UberMedia's offerings.
     
  13. Sachz macrumors newbie

    Joined:
    Jul 12, 2009
    #13
    Twitter

    Well at least the "something is technically wrong" error isn't something that is only technically wrong with me.

    I like the idea of https, but not if it's going to break qTweeter functionality. Tweetdeck came out with an updated 2.0 version today, but it's nothing near what qTweeter provides. Twitter needs to fix their settings page..
     
  14. Mackinch macrumors newbie

    Joined:
    Oct 30, 2009
    Location:
    South East England, UK
    #14
    Anyone know who we can tweet to make them aware that this issue is a real PITA ?
     
  15. Sachz macrumors newbie

    Joined:
    Jul 12, 2009
    #15
    Twitter

    Just did. Since they have close to 5 million followers, I doubt they'll notice. I'm about 45 minutes away from their office. I should just head down there with a bouquet of beer and a "please :D".
     
  16. Mackinch macrumors newbie

    Joined:
    Oct 30, 2009
    Location:
    South East England, UK
    #16
    Well, it worked. Theres no error now.
    I got https now off and QTweeter running a tweet (sorry :p )
     
  17. Sachz macrumors newbie

    Joined:
    Jul 12, 2009
    #17
    Twitter

    Whoa! It did! I wonder if they saw my 1 in a 1,000,000,000 tweet. :p

    So does that mean qTweeter works fine for everyone now?
     
  18. johnnyxhuynh macrumors regular

    johnnyxhuynh

    Joined:
    Jun 17, 2006
    Location:
    Houston, TX, USA
    #18
    qTweeter works for me after I disabled "Always use HTTPS". Hooray!
     
  19. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #19
    qTweeter locks up for me whenever autocorrect does it's thing. Any ideas for that issue?
     
  20. EmScape macrumors newbie

    Joined:
    May 13, 2011
    #20
    My qtweeter redirects to the settings page any time I try to select either "photo" or "library" ... anyone know what's going on with that?
     

Share This Page