Quake 4 no sound

Discussion in 'Mac and PC Games' started by drumminelsewher, Sep 21, 2007.

  1. drumminelsewher macrumors newbie

    Joined:
    Jan 8, 2006
    #1
    Sorry to re-post this.

    I found the old thread and tried all of the solutions to fix my sound. But I still have no sound through my laptop speakers or my usb bose speakers. So far technical support has been a suckfest.

    Anyone have any idea how I can fix this problem? I'm running it on a macbook pro (17 inch, new model)
     
  2. BornAgainMac macrumors 603

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
    #2
    I applied all the patches and had the same problem but then it went away when I rebooted. Try repair permissions and logging in as another user.
     
  3. drumminelsewher thread starter macrumors newbie

    Joined:
    Jan 8, 2006
    #3

    Well now I have sound through my laptop speakers but still nothing through my usb speakers.

    This is quite frustrating, I bought the system for music and games and so far no games have worked off of the USB system.
     
  4. Southern macrumors regular

    Southern

    Joined:
    May 15, 2007
    Location:
    London, UK
    #4
    I just had a similar problem when trying to run the Doom 3 demo - apparently if you can't output sound at 24bit use the audio midi config utility in the apps folder to change sound output to 16bit. See if that works.

    That said, I have issues of my own with games (what the hell, Apple, go give us switchers some decent graphics card drivers please!)
     
  5. drumminelsewher thread starter macrumors newbie

    Joined:
    Jan 8, 2006
    #5
    Ok when I get home i'll give that a shot.

    the sound system is a bose companion 5. It sounds great when music is being played I can only imagine my games.
     
  6. Kosh66 macrumors 6502

    Joined:
    Jul 15, 2004
    #6
    Check the sound control panel in preferences to make sure the USB speakers are selected as the output.
     
  7. drumminelsewher thread starter macrumors newbie

    Joined:
    Jan 8, 2006
    #7
    I have on both accounts.

    EA games said that they've been having problems with usb systems and quake 4 looks the same the way.
     
  8. dollystereo macrumors 6502a

    dollystereo

    Joined:
    Oct 6, 2004
    Location:
    France
    #8
    Quake 4 sound suck anyway, is a techno music...
    Doom 3 instead is great!!
     
  9. brockumpodness macrumors newbie

    Joined:
    Dec 5, 2007
    Location:
    Springfield, MO
    #9
    This Is The Fix

    Problem:
    An error says that OpenALL is not supported when you try to get the sound working in Quake 4 (for mac).

    Solution:
    1) open Audio MIDI Setup (do a spotlight search, it's easier)
    2) once there, in "Properties For:" choose "Built-in Output."
    3) then in "Audio Output" you'll see right by the "Format" 2ch-16bit/2ch-20bit/2ch-24bit. Choose from the scroll menu 2ch-16bit.
    4) make sure the Hz is 44100.0Hz.

    And the best thing is, THERE'S FINALLY SOUND!!!

    Enjoy ;)
     

Share This Page