Quartz Extreme Stops Working after a while

Discussion in 'Mac Basics and Help' started by Diggity-Dan, Feb 20, 2008.

  1. Diggity-Dan macrumors member

    Joined:
    Feb 6, 2008
    Location:
    Toronto, Canada
    #1
    I'm running 10.5.2 on a 2GHz C2D BlackBook. Recently I've encountered 3 symptoms that suggests Quartz Extreme stops working after the computer's been running for a while (and by a while, I mean it could only be a couple hours).

    I've recently (a few days ago) set my desktop picture to change every minute. It's supposed to fade smoothly between pictures, and it did for a while, but then eventually I noticed the fading transition had stopped and the pictures were just switching without any kind of transition. The problem was resolved after a restart.

    I don't use iMovie often. But I opened iMovie '08 yesterday and I got the following error message: "iMovie requires a graphics card that is compatible with Quartz Extreme. One or more of your graphics cards does not support Quartz Extreme." My only option was to quit iMovie. I noticed my desktop picture was also not doing the transitions any more. After a restart, both problems were resolved.

    Today, I got the same error message in iMovie and the desktop isn't transitioning again. I haven't restarted yet, but I assume it will fix itself when I do. Also, I tried adding a widget to my dashboard to see if I get the ripple effect, to test my theory that Quartz Extreme (or is it core image, or core graphics?) stops working after a while. I did not get the ripple effect I usually get when adding a widget.

    Since I just started using the changing desktop feature and 10.5.2 is a new update, I don't know if one of those could be causing the issue. I'll try turning off the desktop transitions and see if it continues.

    Anyone else with this issue? Or know how to resolve it?

    Thanks.
     
  2. avi4now macrumors newbie

    Joined:
    Mar 4, 2008
    #2
    Same here

    I've got a white 2.2 GHz Santa Rosa Merom, and I'm experiencing the same thing.
     
  3. Diggity-Dan thread starter macrumors member

    Joined:
    Feb 6, 2008
    Location:
    Toronto, Canada
    #3
    I turned off the "change picture" option in the desktop preferences after my original post and haven't experienced the problem since. It must have something to do with that. Is your desktop picture set to change? And if so, how often?
     
  4. mfjko macrumors newbie

    Joined:
    Mar 5, 2008
    #4
    Quartz Extreme

    I am running a 17 inch MacBook Pro and have also received the error message below when trying to open iMovie. I am running 10.4.11.

    iMovie requires a graphics card that is compatible with Quartz Extreme. One or more of your graphics cards does not support Quartz Extreme.

    I was not able to even open iMovie. I shut down my laptop and tried again after restarting but got the same error message.

    Recently I have been having problems using transitions in PowerPoint or slideshows with iPhoto. Is this a hardware or software problem that we are encountering and does anyone have another solution besides turning off the machine?

    This has become a huge problem for me so would appreciate anyone that could enlighten me as to what is going on with my laptop's functionality.
     
  5. avi4now macrumors newbie

    Joined:
    Mar 4, 2008
    #5
    No, it's not.

    No idea so far.
     
  6. mrtune macrumors 6502a

    Joined:
    Jun 23, 2007
    #6
    My macbook does this all the time. Frequently I cannot open imovie or photobooth because it says I don't have a quartz extreme capable graphics card.

    If I go into the system info area it'll say the same thing. Shows it as not supported.

    If I simply log off and back on, then everything is fine again (no need to restart). It will show it as supported in the system info. At first I used to restart, but for the sake of trying it out once, I decided to just log off and on. It had the same effect as restarting, so that's what I do now.

    This all started after I updated to 10.5.2. Never had a problem before. I bought my macbook new in december. It's a big pain in my ass, as I enjoy using both those programs all the time.

    I've been trying to pinpoint when it happens. It has never happened after the computer has been running. Only when it comes out of sleep.
     
  7. lpedro macrumors newbie

    Joined:
    Jun 23, 2008
    #7
    Changing resolution...

    Hi,
    My macbook pro also does this when it comes from sleep. I solved the problem by changing resolution (to any other that the one using by default) and then changing again to the preferred resolution. Opening iMovie afterwords doesn't generates the error any more.

    Hope it helps,

    Cheers,

    Luis Pedro
     
  8. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #8
    I've had this happen when using an external display in clamshell mode and the Mini-DVI adapter accidentally slips out.

    Just log out or reboot and Quartz Extreme will be back. There's some strangeness in OS X when it comes to swapping displays and waking from sleep that's the cause.
     
  9. jsmithsole macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    So Cal
    #9
    I had the same problem, reboot worked but still annoying and every forum I have checked, there's no real solid answer...:mad:
     
  10. Lunalova macrumors newbie

    Joined:
    Aug 15, 2008
    #10
    Same thing

    I've got the same thing, i will try to reinstall QuartzComposerAppSupport.pkg later today, maybe that will work...:confused:
     
  11. kev319 macrumors newbie

    Joined:
    Nov 9, 2008
    #11
    EarthDesk conflict

    I had the same exact problem.

    After using Imove for a few years on my G5, it suddenly quit working.

    I took a cue from one of the earlier posts and turned off EarthDesk as my active desktop. Once I restarted my computer, the error message disappeared.

    I'd say make sure your desktop is stationary and see if that helps.
     
  12. FénixMagnesio macrumors newbie

    Joined:
    Aug 28, 2009
    #12
    A clue (also my first post)

    I don't have a full explanation for this glitch, but here is what was causing the problem in my case. I had my display in grayscale. Not only did iMovie give the error message, System Profiler actually thought Quartz Extreme was "Not Supported". I unchecked the grayscale option, and everything (once I reopened it) was back to normal.

    So the moral of the story is that any aberration in display settings, even outside of the Displays panel, has the potential to upset the status of graphics.

    By the way, iMovie '06 has the same error message, but gives you the option of starting it anyway. (As if '08 wasn't lacking enough functionality.) Also, the changing wallpaper didn't cause me trouble. However, we are talking about different versions of OS X. I'm running 10.4.11, as is mfjko.

    If you're wondering why I was using grayscale: I turn it on to remind me of another temporary setting - in this case, having the computer to never go to sleep.

    Reported causes:
    • Change picture (Desktop & Screen Saver)
    • Use grayscale (Universal Access)

    Let's keep this list going; I'm sure there are other triggers. Keep careful note of everything you do until Quartz goes AWOL.

    Reported fixes:
    • Restart
    • Log Out, Log In
    • change resolution (Displays)
     
  13. snorkeler macrumors newbie

    Joined:
    Oct 31, 2009
    #13
    Same problem on Mac Mini

    I have a Mac Mini purchased early 2009. It came with iMovie 08, and it has worked fine. I upgraded to Snow Leopard, and it still worked fine.

    Then, upon returning and restarting it, now iMovie gives the same error message cited here. Changing resolutions does not resolve the problem.

    I tried twice to set up an Apple support call. Very annoying--twice, after entering everything, it messaged "your call cannot be arranged at this time. Please try again later." Nice.

    It certainly seems Apple has a system bug here. It would be nice if they didn't charge you for fixing it or at least giving you a workaround.

    Update: a restart solved the issue.

    It would be nice if you could find this fix via Apple support. Thanks to Macrumors for being here.
     
  14. Floyd Atheus macrumors newbie

    Joined:
    Aug 25, 2010
    #14
    Quartz Graphics Card

    Thought I'd chip in. Useful thread. Same problem. MacBook Pro OSX 15.8. I often use an external display which I unplug without shutting down. Got the error message trying to open iMovie 8.0.6. The previous post about switching display resolution was bang on (thanks iPedro): no need to restart or log out. Simply switch out of your usual display resolution (choose any) then switch back in. Until Apple sorts it out, this is relatively painless.
     
  15. comandantequito macrumors newbie

    Joined:
    Oct 11, 2010
    #15
    hope this works...

    started getting this problem last night.
    i tried Luis Pedro's suggestion below, restarted the computer, opened iMovie & it worked.
    will update if problem persists.
    thanks!
    Q.

     
  16. omedome macrumors newbie

    Joined:
    Mar 2, 2011
    #16
    Quartz Extreme no longer supported

    Both my mac-minis developed the "Quartz Extreme no longer supported" problem. I started my project on one then switched to the other. Reinstalling the system fixed this problem for me. It's a tedious fix but I was on a deadline and none of the other "fixes" were working for me (like changing the display settings or restarting) Plus I ran out of computers to switch to. I was surprised that this problem goes back to early 2008 and Apple has yet to address it in any serious way. I did an exhaustive search and finally came across the re-install fix at ifixit.com.
     

Share This Page