Quartz GL will alleviate all animation related problems

Discussion in 'macOS' started by wankey, Sep 3, 2009.

  1. wankey macrumors 6502a

    Joined:
    Aug 24, 2005
    #1
    NVM, also disable the BeamSync And make sure you reboot!

    Disabling BeamSync gave me 100+FPS, enabling made it max out at 25FPS

    Title is misleading, delete thread plz.
     
  2. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #2
    how do you get quartz debugger? i did a search with spotlight and nothing came up with it. is this method also for snow leopard?
     
  3. wankey thread starter macrumors 6502a

    Joined:
    Aug 24, 2005
    #3
    Yes, it's in

    Developer / Applications / Performance tools / Quartz Debugger

    Open it, options Beam Sync = Disable.

    Force quit (this is key)

    Reboot

    Reap in the 100+FPS. Dock is SUPER smooth. My mac feels 1000000x faster now. Faster than Windows even.

    Absolutely no issues with animation... it's like laughable now that my comp had issues with animation. Everything is rediculously smooth.

    Also don't turn on Quartz GL, your dashboard gets screwed.
     
  4. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #4
    sorry, where is this at?

    "Developer / Applications / Performance tools / Quartz Debugger"
     
  5. sammich macrumors 601

    sammich

    Joined:
    Sep 26, 2006
    Location:
    Sarcasmville.
    #5
    Coolness. Bringing up the frame meter (under Windows, or command-3) shows that the frame rate almost doubles for whatever animation related task (like scrolling in safari, expose, spaces.

    Wow, expose sucks when you disable this. I'm out.
     
  6. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #6
    so i got quartz debugger to work. had to install from SL CD.

    disabling does make animation a lot smoother. its like stupid smooth. feels good. but how do you make it stick? i force quit and reboot and it still goes back to automatic.

    once i force quit, i can tell the animation is back to being choppy.
     
  7. wankey thread starter macrumors 6502a

    Joined:
    Aug 24, 2005
    #7
    Weird, it works for me, but I did an upgrade from Leopard rather than a clean install. I'll try to figure this out.

    Also, thsoe who are having issues with expose being very very choppy when disabling BeamSync, make sure you reboot or wait a while. I originally thought it was a bad idea because instead of boosting my fps, it dropped my fps from 25 to 10, but once I waited a while, rebooted, did the same thing over again, it jumped to 100fps.

    I can't believe Apple is limiting people's hardware because of "tearing"

    They seriously need to fix the VSync. It's quite obvious that they've screwed something up as it's limited to half my refresh rate rather than the 60fps which most LCDs refresh at.
     
  8. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #8
    i read that beam sync is only good if you're using CRT monitors, it wouldnt matter for LCD. since im on my umbp, i really dont need beam sync correct? it feels sooo much smoother and better when beam sync is disabled. but i have to keep quartz debug open. there should be a permanent way to do this.
     
  9. wankey thread starter macrumors 6502a

    Joined:
    Aug 24, 2005
    #9
    No that's a misconception. LCDs also have refresh rates which are actually worse than CRTs. Since CRTs refresh much faster though, the speed is quite fast. However, since LCDs refresh much slower, I think VSync puts a FPS limit to around 30 instead of 60.

    It works for me when I force quit the program as it's running. Then reboot.
     
  10. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #10
    is it because im on a laptop thats why it wont stick? i dont know how to make it stick. its not working for me.
     
  11. wankey thread starter macrumors 6502a

    Joined:
    Aug 24, 2005
    #11
    I'm on my macbook pro. Man I can't believe I've been running this BeamSync crap. My computer feels 1000000x faster. Games feel 10000x more responsive and frame rates have jumped multitudes, not just a few percentage increases.

    Literally it went from 25FPS, to off the scale, the FPS hand goes way off the dial using the Quartz plugin. It's 100+FPS at least.
     
  12. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #12
    can you tell me how you get yours to stick? like steps? im having heck of a time trying to make it work. i can leave quartz debug open all the time, but its kind of lame to do that. this is what i did:

    open quartz debug
    under beamsync : i disabled
    then force quit quartz debug
    reboot

    open quartz debug again and noticed that its back to automatic. are there any pref file or terminal code i can use to make it sitck?
     
  13. wankey thread starter macrumors 6502a

    Joined:
    Aug 24, 2005
    #13
    Lemme try to reboot. It seems to work for me for now.

    I use spotlight, quartz debug.

    Then do exactly the same, except I right click the icon in the dock, press option and quit turns into force quit. And click that, it'll quit. And it'll stick.

    Actually, it isn't stick for me either. I really wish Apple will simply fix the VSync code to sync all things to 60fps rather than 24fps. Heck without the sync the FPS is rediculous. Dock makes the FPS meter shoot up to 90fps, with the sync it only shoots to 10fps. Pathetic.
     
  14. cubedweller macrumors 6502

    Joined:
    Nov 25, 2007
    #14
    Yea, I can't get it to stick either. :mad: It looks so much better with it disabled. I hope 10.6.1 fixes this issue.
     

Share This Page