Question about iMessage.

iRobby

macrumors 6502a
Original poster
Mar 22, 2011
994
5
Fort Myers, FL USA
Got a question about iMessage status.

I'm able to initiate a new message inside the app. However, I'm not receiving new conversations from others unless I initiate the conversation first. I noticed that on the menu bar there is a dim message icon. When I right click it status menu appears. On top it says I'm offline. Even when I'm in a conversation that I initiated. Same goes for the icon in the dock.

I try to select online status on both dock and menu bar icons. Nothing happens. Status remains offline.

I'm familiar with iMessage on iOS. If I have a problem I go to settings. But I don't see a setting under preferences in OSX for messages.

I'd think there would be a place to manage your iMessage account.

What am I missing?
 

Gemütlichkeit

macrumors 65816
Nov 17, 2010
1,276
0
Message app and iMessage doesn't require an "online" status. It's active as long as you have a wifi signal established.

Are you also tying in an iOS device with this or are you using iMessage strictly with Mountain Lion?
 

ac3320

macrumors regular
Aug 20, 2011
127
0
CA
Same problem here. It used to be a full drop-down menu with options like "Available," and "Set Away Message," etc. Also, it was greyed out in 10.8.1 and previous versions if you had quit Messages and set in the Messages prefs to "go offline when quitting." It's grey all the time now :/ I also cannot hit the "+" sign to add a Google Talk account.

 

cosimolupo

macrumors newbie
Aug 25, 2012
14
0
Messages.app's menubar status item is only for IM services such as GTalk and not for iMessage, which is always "online" as long as it has an active internet connection, even while the application is closed -- as @Gemütlichkeit has already explained.

@ac3320
If you want to add a Google Talk account, simply go to Messages.app's Preferences (⌘,) in the "Accounts" tab, and then click the plus sign.
 

ac3320

macrumors regular
Aug 20, 2011
127
0
CA
Messages.app's menubar status item is only for IM services such as GTalk and not for iMessage, which is always "online" as long as it has an active internet connection, even while the application is closed -- as @Gemütlichkeit has already explained.

@ac3320
If you want to add a Google Talk account, simply go to Messages.app's Preferences (⌘,) in the "Accounts" tab, and then click the plus sign.
Yeah. I tried that. When you click the "+" nothing happens. I said that before, but you missed it I think.

Another silly thing is that all my saved conversations are gone, but that could be unrelated to anything I suppose.
 

cosimolupo

macrumors newbie
Aug 25, 2012
14
0
do you mean *this* plus button?



this is very strange indeed. If I click the button the following window should appear:

 

iRobby

macrumors 6502a
Original poster
Mar 22, 2011
994
5
Fort Myers, FL USA
Message app and iMessage doesn't require an "online" status. It's active as long as you have a wifi signal established.

Are you also tying in an iOS device with this or are you using iMessage strictly with Mountain Lion?
I use iMessage on the iPad and iPhone as well and want it to sync all 3 devices.

My conversations sync on the iOS devices. I understand that the status on the menu bar is for other chat clients linked. But since they aren't greyed out on my MacBook Pro Retina that it also applied to iMessage.

Also, I can't find where I set the address to receive messages like on the iPad and iPhone
 

Arelunde

macrumors 6502a
Jul 6, 2011
980
28
CA Central Coast
It's really important that your RECIPIENTS have their "@me.com" email added to Messages and iMessage settings - in addition to their phone number. Once that is done, these issues should be resolved and the messages will show up in Messages on all devices/computers.
 

joshforman

macrumors regular
Aug 11, 2012
108
2
I'm guessing your friends are sending a message to your phone number and messages are getting delivered to your iPhone only. Macs and iPads currently cannot associate themselves with your phone number on your iCloud account. This will be rectified in iOS 6 at which point your phone number will appear as an option under "You can be reached by iMessage at" on everything.
 

iRobby

macrumors 6502a
Original poster
Mar 22, 2011
994
5
Fort Myers, FL USA
I'm guessing your friends are sending a message to your phone number and messages are getting delivered to your iPhone only. Macs and iPads currently cannot associate themselves with your phone number on your iCloud account. This will be rectified in iOS 6 at which point your phone number will appear as an option under "You can be reached by iMessage at" on everything.
that occurred to me. Also I answered another question on my own.

I was wondering why like in IOS there weren't any preferences or settings for each application.

I figured out there isn't a window but instead for each application the preferences are on the menu bar when the application is open and in use under the name of the specified application.
 

cosimolupo

macrumors newbie
Aug 25, 2012
14
0
@iRobby
Now that you have setup iMessage correctly, can you tell us if, when you receive a new message and the app is in background, you also get a banner notification on the upper-right part of the screen, plus a sound notification?
As I have explained elsewhere on this forum, I'm having problems with banners/sounds and specifically with iMessage (not the other IM services).
Thanks, and sorry for hijacking your discussion.
 

iRobby

macrumors 6502a
Original poster
Mar 22, 2011
994
5
Fort Myers, FL USA
@iRobby
Now that you have setup iMessage correctly, can you tell us if, when you receive a new message and the app is in background, you also get a banner notification on the upper-right part of the screen, plus a sound notification?
As I have explained elsewhere on this forum, I'm having problems with banners/sounds and specifically with iMessage (not the other IM services).
Thanks, and sorry for hijacking your discussion.
Yes, if I either minimize it with the yellow button and it animates to the icon or when I close the window via red button I still get the banner and sound notification.

The only time I don't is when I right click the icon on dock and press "Quit"
 

cosimolupo

macrumors newbie
Aug 25, 2012
14
0
Thanks @iRobby

Can I ask you another little thing?
Would you mind doing the following brief test:

1. Send yourself an iMessage from a different account and device, while Messages app is open but hidden or in the background. Before you do that, however, make sure that there are no open conversations with that particular buddy from which you are sending the test message (I mean, the chats that appear on the left-hand side of the main window). Otherwise, close the conversation (menu File -> Close Conversation) and then send the test message with the app in the background.

In this scenario, you should correctly receive the banner notification and hear the sound. So far so good.

2. then, activate Messages and put it in the foreground, maybe also reply to the test message. Don't close the active conversation and hide the app again.

3. Now, try again to send youself another test iMessage, and check whether you receive a banner notification and can hear the sound notification also this time...

If you don't, then there is clearly something wrong with the implementation of iMessage in OS X Mountain Lion; while if you do get the notifications then, either my Mac is having fun of me or I am going mad! ;)

Thanks very much for your help.