Question about iTunes Match? (7.1)

lewismayell

macrumors 6502a
Original poster
Mar 24, 2013
613
21
South West England
So I upgraded to 7.1 and it has changed my iTunes Match, before I only had the albums in my iCloud library visible (which is what I prefer) now I can see all my previous purchases, which I don't want to do, question: how do I stop my purchased music being shown?
 

dannyyankou

macrumors G3
Mar 2, 2012
8,634
12,598
Scarsdale, NY
Settings > Music > turn off "show all music"

Edit: Actually, the only way to keep iTunes Match on is to keep "show all music" on, so I'm not sure it's possible.
 
Last edited:

Nunyabinez

macrumors 68000
Apr 27, 2010
1,759
2,209
Provo, UT
So I upgraded to 7.1 and it has changed my iTunes Match, before I only had the albums in my iCloud library visible (which is what I prefer) now I can see all my previous purchases, which I don't want to do, question: how do I stop my purchased music being shown?
I am not experiencing the same thing as you are. Only my matched items are there.

If it were me, I would check to make sure that any computers that are associated with match don't have those tracks downloaded, and then I would turn match off on my phone and turn it back on. Sorry I can't be of more help.
 

Nunyabinez

macrumors 68000
Apr 27, 2010
1,759
2,209
Provo, UT
To test this out I disabled iTunes match and re-enabled it, and sure enough, I now get the exact same behavior. Apparently this is a new "feature." I'm going to go enter a complaint since there is no way to exclude these songs like there is for songs manually added to iCloud.

----------

So I upgraded to 7.1 and it has changed my iTunes Match, before I only had the albums in my iCloud library visible (which is what I prefer) now I can see all my previous purchases, which I don't want to do, question: how do I stop my purchased music being shown?
Hey! I figured it out. This is what you have to do. Go to your iTunes library on your mac. Download the purchase. You might have to go to your account page to find all your past purchases. After it downloads, delete the track from your iTunes library and make sure to check "Also delete this song from iCould." It will then be gone from your phone.
 

lewismayell

macrumors 6502a
Original poster
Mar 24, 2013
613
21
South West England
To test this out I disabled iTunes match and re-enabled it, and sure enough, I now get the exact same behavior. Apparently this is a new "feature." I'm going to go enter a complaint since there is no way to exclude these songs like there is for songs manually added to iCloud.

----------



Hey! I figured it out. This is what you have to do. Go to your iTunes library on your mac. Download the purchase. Delete the purchase from your iTunes library and make sure to check "Delete from iCould." It will then be gone from your phone.
I think that is what I did the first time, but this time it just disappeared when I looked at my purchases haha