Question about my ipod touch 2g

Discussion in 'iPod touch' started by teknofile9, Mar 22, 2011.

  1. teknofile9 macrumors newbie

    Joined:
    Mar 22, 2011
    #1
    Im sure if I read thru the forums i would answer my own question, but Ive been dealing with refurbishing my ipod for 2 days and im almost done. Here is my question. Ive replaced the LCD and digitizer, and figured out the battery needed replacing too. So i got out my soldering iron and replaced the battery and put everything back together. Turned it on and wow, it worked (much to my surprise since ive never used a soldering gun before). When on the home screen it said battery 20% so I plugged it in and left it last night. Came home after work figuring it would be fully charged today, but when I unplugged it, it still said 20%. So I read up online and came to the conclusion the middle pad wasn't soldered correctly, so I opened it up, heated up the gun and reworked it. Now the screen shows a empty battery with a red line and a white lightning bolt. When i unplug it it shows the same battery and a plug, arrow, bolt. I hit the power button but it does nothing (even holding it down for a few seconds). How long do I have to wait for it to charge up? its been on the plug for about an hour now.

    also, on the bezel i ordered for a ipod touch 2g, the home button contact does not line up with the contact inside the unit. in fact its on the opposite side. I checked the site I ordered it from and it says its a 2g bezel. Anyway to mcguyver this without having to buy another bezel (thinking on soldering a piece of wire off the contact to the metal harness...).

    Thanks for any help or insite on this!!
    Dan
     
  2. teknofile9 thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #2
    things have changed now...

    ok, i think I fixed it. I re soldered the connections, and now it turns on (with it plugged in) and I don't get the "your battery is below 20%" message. The little white icon tho goes between a white battery with a black plug, and now its on a white battery with a black bolt? is this the right thing it should be doing? I figured the animation would be fancier, lol.

    so, does this soung like its now working. and does anyone use that mQuickdo app. Im trying NOT to have to get another bezel where the contacts line up. Is the home button all that important if I can get an app that allows me to swipe to get to the home page, rather then turning it off and on every time? thanks for your help!
     

Share This Page