Question about Wireless N capabilities of my uMB

Discussion in 'MacBook' started by SuperSnake2012, Jan 31, 2012.

  1. SuperSnake2012 macrumors 6502a

    Joined:
    Oct 11, 2005
    Location:
    NY
    #1
    Hi guys. I have a late 2008 unibody Macbook. I just bought a Medialink MWN-WAPR150N wireless N router the other day to replace my dying Linksys router. It works great, except OS X is showing that it's only connected to my router on G speeds:

    [​IMG]

    On the router settings, I have it set to mixed b/g/n mode. My computer shows that it supports N, but it's only connected as g. Does anyone have any idea what's wrong?

    My router's settings:

    [​IMG]
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Try creating a dedicated 802.11n network and see what happens.
     
  3. sohir macrumors newbie

    Joined:
    Jan 18, 2013
    #3
    same issue

    I have exactly the same issue.

    The router does not have an option of setting to N mode only. The only way to set it to N is to select B/G/N mode.
     
  4. sohir macrumors newbie

    Joined:
    Jan 18, 2013
    #4
    solution

    I contacted medialink and they sent me the following solution. Not sure why it works but my network now shows up as wireless-N.


    Try adjusting the security you are using on the network.
    Login to your router's ip at 192.168.0.1 from a browser window (login "admin" "admin").
    Under Wireless Settings> Security Settings, make sure your security mode is set to Mixed WPA/WPA2 and you are using both algorithms (TKIP and AES)> Apply.
    You'll then want to "forget" the previous network connection. For example, on Win 7 and Vista, Start> Control Panel> Network and Internet> Network and Sharing Center>Manage Wireless Networks> Right Click and remove ALL entries for your home router (called Medialink or whatever you may have re-named it). Then return to Network and Sharing>Connect to a Network, and re-enter your password to reconnect.
     

Share This Page