Question concerning installing mac software and Crossover

Discussion in 'Mac Basics and Help' started by radionickhead, Nov 5, 2008.

  1. radionickhead macrumors regular

    Joined:
    Sep 6, 2008
    #1
    Hey,
    I'm new to mac hence all the questions, I apologize for having to create new threads each time but I come to dead ends.
    Two questions:
    I recently installed coq from : http://coq.inria.fr/ - It's a dmg file which when I mount opens a .pkg file. I opened the installer, chose my mac HD, and I waited for it to write the files...after the installation was over it wasn't in the applications folder, and I used spotlight and couldnt find coq anywhere..
    I tried re-installing,dragging and dropping to applications e.t.c
    and I just can't seem to find it, I must've installed it 2-3 times..
    I'm afraid that I must've done this for other software (after I figured out how to drag and drop)
    - So where is all my software going?
    - Wheres coq?

    - On another question, I messed around with crossover pro, and managed to install steam and it worked. I downloaded cs and installed it e.t.c - I played the game and everything, but I can't seem to find the installed folder. I tried looking for a .cfg to edit some of my settings but can't find it anywhere.

    I don't think I'm installing the software correctly or at all maybe?
    Some help please?
     
  2. yippy macrumors 68020

    yippy

    Joined:
    Mar 14, 2004
    Location:
    Chicago, IL
    #2
    Coq is not a normal application with a gui. It is a command line application which means to run it, open up a program called Terminal (found in the Utilities folder) and type coq and then hit enter. For more information on how to use it read its manual.

    As for where crossover files are installed, I don't know, you might try your library->Apllication support folder, otherwise I would contact the developer about that.
     
  3. radionickhead thread starter macrumors regular

    Joined:
    Sep 6, 2008
    #3
    Thanks for the response..
    I know it's command line - driven but I thought it had a GUI interface to it.
    None-the-less I've already tried coq in the terminal and it still doesn't work :/
    Command not found, it's as if I didn't install it
     
  4. radionickhead thread starter macrumors regular

    Joined:
    Sep 6, 2008
    #4
    Ive figured out how crossover more or less works..
    Found the C drive...still can't get coq to work :/
     
  5. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #5
    It may be that the path to the coq command line is not set. You may need to change directory manually, for example to /usr/local/bin before executing the command.

    It seems there is another package with a GUI on the site you posted above, named coqide. Maybe that was the one you wanted to install.
     
  6. radionickhead thread starter macrumors regular

    Joined:
    Sep 6, 2008
    #6
    I still haven't gotten coq to work..
    I've downloaded proof general and edited .emacs and after I type in a proof, and perform C c C n, it says coqtop not found...
    I've even tried installing windows coq through crossover but it installs but when I run it it opens two windows with huge text and I cant make out what it says..
     
  7. radionickhead thread starter macrumors regular

    Joined:
    Sep 6, 2008
    #7
    You seem to be right, the coq files are in /usr/local/bin - and can only be used in that directory, how can I make them universal?
    Btw it still doesn't work when I create a file in /usr/local/bin ..
    Proof general loads but it can't seem to find coqtop - even though its in /usr/local/bin
    any ideas?
     

Share This Page