Question Mark Folder, and ejecting Startup Disk

Discussion in 'Mac Basics and Help' started by Jebaloo, Sep 30, 2007.

  1. Jebaloo macrumors 6502

    Sep 12, 2006
    Hi, I'm sorry if I get some of the terminology wrong here.

    My computger shows the flashing question mark in a folder icon upon booting just after the chime. I've been reading up all about it and am pretty clear about what actions I should take.

    The very first direction that all instructions give me is to insert the Startup CD, shut down, and then restart holding down the 'C' key. The problem I'm encountering is that a little while after starting up, the computer ejects the CD, and then goes onto show the flashing question mark again. I'm pretty sure i'm inserting the correct CD as it does itself have the directions to hold down 'C' for booting from CD printed on it. I've tried the other CD which came with my MacBook too, but the same result.

    I've booked a slot with a Genius on Tuesday, but does anyone have any suggestions as to why it would be ejecting the CD?


    p.s I've also tried to boot in target disk mode, and although the attached PowerBook sees the harddrive in disk utility, the repair utilities are greyed out, and it doesn't see it in finder so can't access the contents.
  2. Naimfan Suspended


    Jan 15, 2003
    Wow. Sorry to read this!

    The only things I can think to suggest are things you've probably already tried. First, have you tried booting in safe mode? Second, can you try booting off of an external drive? Because the combination of the MB (I assume) ejecting the disc and showing the question mark makes me think it may be a bad logic board.

    Good luck on Tuesday!
  3. Jebaloo thread starter macrumors 6502

    Sep 12, 2006
    Hi, thanks for your advice. I'm not really sure what safe mode is, is it when you hold down shift as you boot up? I'm going to try booting off an external drive tomorrow.

    It's in warranty, so it should hopefully be a free repair, but if I lose the HD, then... I'll lose 4 photoshoots, silly be for forgetting to back-up for a couple of weeks.
  4. Naimfan Suspended


    Jan 15, 2003
    Here's the Apple article on booting in safe mode:

    Essentially, make sure the computer is off, press power, and once you hear the start-up chime THEN press and hold the "shift" key. Then release the shift key when you see the gray Apple and spinning gear. Hope that works!

    And hopefully it's something minor that they can fix on the spot! I'll cross my fingers......
  5. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Two more things you can try are using the boot selector menu (hold just the option key on boot; sometimes works when holding c does not) and running the Apple hardware test (insert the install DVD -- it's a DVD, incidentally, and not a CD -- and hold 'd' during boot).
  6. Jebaloo thread starter macrumors 6502

    Sep 12, 2006
    Sounds promising. Thanks so much for advice. I'll sleep a little easier tonight.

    I'll let you know how it goes.
  7. richard.mac macrumors 603


    Feb 2, 2007
    51.50024, -0.12662
    have you fixed it yet?

    when you boot into the install cd select you language, then go to the utilities menu and select disk util and repair permissions, disk etc. then choose startup disk and choose your OS X volume and click restart. it should work after this. if it doesnt you could try holding command-option-P-R after a restart and let go after the second loud chime. it should work then. if not it might need repair.
  8. Naimfan Suspended


    Jan 15, 2003
    I just KNEW there was something I was spacing, and rich just said it. Definitely try that if you haven't already--IIRC, you are resetting the parameter RAM. Often works!
  9. Jebaloo thread starter macrumors 6502

    Sep 12, 2006
    Well, so far I've tried doing a Safe Boot, by holding down the shift key just after the chime. It took a lot longer than usual, but eventually the plain screen was replaced by the flashing question mark folder. No luck.

    My friend just tried booting it from an externmal firewire disk on which I have a disk image, and all it did was bring up a scary black screen with all sorts of MSDOS style writing. He took out the drive and now it's not looking so good. He's trying to re-build it using disk warrior. Strange stuff.

    I'm just going to try some of those other options.
  10. Jebaloo thread starter macrumors 6502

    Sep 12, 2006
    New development.

    I put in the startup disk and didn't press any buttons, only the power button to turn off, and then to startup again. Without pressing C it went into the Disk Utility thing, after choosing my language.

    Looking at the disk utility and trying to choose my startup disk has shown that the internal hard drive isn't showing up.

    It's just not there!

    Don't know what to do now.
  11. Jebaloo thread starter macrumors 6502

    Sep 12, 2006
    I've reset the PRRam, I think. It chimed twice and I did what you said, but afterwards it just went to the same old grey screen - I turned it off after a couple of minutes.

    Am now trying to boot from the Startup Disk again - after this I going to work and waiting till Genius on tuesday.
  12. Jebaloo thread starter macrumors 6502

    Sep 12, 2006
    Ongoing. I think the fact that I'm posting so many problems means I should just wait for a genius, but I managed to gety the internal disk to show up in disk utility, and I ran a rapair disk.

    "Verify and repair disk "disk0s2"
    Checking HFS Pure volume
    Invalid B-tree node size
    Volume check failed.

    Error: The underlying task reporrted a failiure on exit

    1HFS volume checked
    1volume could not be repaired because of an error"

    Hmm... No idea what this means, but at least the disk showed up this time, this is after doing PRam reset.
  13. EssentialParado macrumors 65816

    Feb 17, 2005
    Jebaloo, someone I know has a similar problem. Did you fix this?
  14. aesteban macrumors newbie

    Aug 10, 2009
    Problems with Macbook Question Mark Folder

    On my white MacBook startup I got a flashing Question Mark Folder (QMF) and a slight clicking noise. I figure clicking noise is bad HD so I buy new one. I replaced HD, reset PRAM and still get QMF when I try to boot with install CD in drive (pressing/holding C on startup). So I do the remote install with my Desktop and Firewire cable and the install goes great. I see the new drive in the MacBook got all the files installed. But, when I try to boot up I still get the QMF. Is this no longer a HD problem, but a more expensive problem (logic board..$omething else) ?

    Thanks in advance to anyone who takes the time to reply,
  15. aesteban macrumors newbie

    Aug 10, 2009
    Re: Problems with Macbook Question Mark Folder

    I just found out that I had installed OSX 10.3.7 which is not meant for the Intel processor machines. Problem solved. I have to buy a version of the OS X that does work with Intel CPUs.
  16. goldenapple macrumors newbie

    Mar 3, 2010

    I'm interested to hear how the outcome of this thread as I am going through something similar right now.

    Any advice?

Share This Page