Question Mark of death after Volume Rebuild...

Discussion in 'Mac Basics and Help' started by anewlanguage, Aug 9, 2011.

  1. anewlanguage macrumors newbie

    anewlanguage

    Joined:
    Aug 9, 2011
    Location:
    Lowell, MA
    #1
    I've run into a problem and while I'm nearly always able to troubleshoot and fix things myself, I'm at a loss for this one. Here's what's happened:

    I have a MacBook Pro (really I don't use it much, my fiancee does mostly), and this is the only thing I own that I don't have any backups of. The other day I was using TechTool to run some maintenance on it... file optimization, disk optimization, etc. However when I ran the Volume Rebuild utility, it wouldn't complete successfully. So I used DiskWarrior instead for the volume rebuild. It may be worth noting that I was doing this all from my MacPro with the MacBook hooked up via firewire in target disk mode. Anyway, DiskWarrior did it's thing, and said there would be files changed (red text instead of green) with the new directory. This is where I did the stupidest thing I could have done... I was in a hurry to get out of the house, so I just let it write the new directory without checking out the changes.

    After this, when I tried to boot the MacBook Pro, I got the dreaded question mark folder on startup, meaning it doesn't recognize a valid OS. So I went back to target disk mode, and it shows up only the disk formerly (obviously by default) named "Macintosh HD" is now named "untitled". And when I look at the info on it, the hard drive capacity is 120GB and the free space is now just about the entire hard drive. There's nothing on there when I open it, and it says the whole thing is free space. :eek:

    This is when I begin freaking out because so much of my fiancee's stuff is on here, and nowhere else. So I used data recovery utilities to get the approximately 100GB of data back, but now it's just in folders named "pictures", "music", and "documents", that contain files such as "file0001.jpg", etc. It's literally every file from the little icons from various programs, to all of her cherished photos. And it would take forever to sort through all of this to figure out what's junk and what's her stuff.

    I'm guessing that whatever the file is that keeps the directory structure is just gone or lost somewhere in there. I've tried booting from an OS X disc and running repair on disk utility... it comes up with no problems. Tried repair utilities on DiskWarrior and TechTool with no luck as well.

    Is there ANY WAY to repair the directory structure so I can at least see the user folder so I can just back that up and re-install?

    Any help or insight into this would be greatly appreciated as I'm losing my mind right now. Thanks in advance. Also I did search the rest of the forum for help, but didn't find any scenario quite like this.
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    If you've already gone so far as to run data recovery software, I'm going to say that unfortunately there's no way to get your drive back to its previous state. Be grateful that your data recovery software was able to salvage as much as it did.

    At this point I'd back up the salvaged files to an external and do a clean install of the OS. At that point you can copy your salvaged data back and start slogging through it. Yes it will be a time-consuming process, but I'm afraid that it's the only option at this point.

    Consider this a learning experience. When doing low-level maintenance on your hard drives, ALWAYS back up first. It doesn't take much of an error by one of those programs to hose your file directory.
     

Share This Page