question on my baseband and going to 4.3.1

Discussion in 'Jailbreaks and iOS Hacks' started by digitalduck, Apr 4, 2011.

  1. digitalduck macrumors regular

    Joined:
    May 8, 2008
    #1
    Before i begin my jailbrake, i have 03.10.01 baseband and have saved them with tiny umbrella, but do I need to do anything on my end or is it too late for me? Meaning is my baseband old enough to worry about it or is it so new that it makes no difference? Just want to make sure i am doing everything correct before i finally upgrade to 4.3.1 thank you!
     
  2. digitalduck thread starter macrumors regular

    Joined:
    May 8, 2008
  3. himni macrumors regular

    Joined:
    Sep 24, 2009
    #3
    Is this a iPhone 4?

    Well if so your BB is not unlockable then so you are probably fine updating to 4.3.1 and letting it update your BB.

    Do you need/want or been waiting for an unlock? If you don't then just update to 4.3.1 and let it update you BB also. If you want to update you BB and you have use TinyUmbrella in the past you need to 1. Open TU and select the 'Advanced' tab. 2. uncheck the box 'Set Hots to Cydia on Exit' then close TU.

    Then you can update to 4.3.1 and proceed to jailbreak. If you preserve your BB you are likely to have some problems with 4.3.1.
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    Base on the baseband 03.10. OP has the Iphone 4 running 4.2.1 ISO.
     
  5. himni macrumors regular

    Joined:
    Sep 24, 2009
    #5
    I was pretty sure it was but the OP didn't say what he/she had other than 3.10.01 so I just wanted the information to be clear. Also other people looking for help later on might not know that 3.10.01 is a iPhone 4 baseband.
     
  6. whiskeyvol macrumors regular

    Joined:
    Mar 14, 2011
    #6
    i still don't understand the baseband thing.

    mine is 04.10.01 on iphone 4

    should i have any issues jb'ing?

    thx
     
  7. sbddude macrumors 6502a

    Joined:
    Sep 27, 2010
    Location:
    Nor Cal, USA
    #7
    Baseband version matters only to unlockers. Only the first baseband of 01.59 was unlockable on iphone 4. Once you upgrade to a newer baseband there is no going back.
     
  8. himni macrumors regular

    Joined:
    Sep 24, 2009
    #8
    You are fine to jailbreak. You have the latest BB for the iPhone 4.

    Unless you unlock or want to in the future you need not worry about it. If you use ever TinyUmbrella and you get a 1013 error when you upgrade to a new iOS that means your BaseBand did not get updated and unless you wanted to do that you need to follow the directions I gave in my earlier post.

    The BaseBand is what controls the cell radio and the version # is what version of the BaseBand software it is running. Lots of people like to keep older versions so they can unlock them to run on unofficial carriers. When there is a new version of iOS out Apple usually updates the BB and if you are an unlocker or want to be able to unlock in the future (if you travel out of country or you want to get more when you sell your iPhone) you want to keep the old baseband and that is why some people have versions older than 4.10.01.
     
  9. whiskeyvol macrumors regular

    Joined:
    Mar 14, 2011
  10. digitalduck thread starter macrumors regular

    Joined:
    May 8, 2008
    #10
    Thanks guys! I was more wondering about resale value down the road. If I should save for a possible unlock or something for potentially selling it later
     

Share This Page