Question regarding iPhone 4 and unlocking

Discussion in 'Jailbreaks and iOS Hacks' started by slipper, Oct 18, 2011.

  1. slipper macrumors 68000

    slipper

    Joined:
    Nov 19, 2003
    #1
    I currently have an iPhone 4 on iOS 4.0 with baseband 1.59.00. Its currently unlocked and jailbroken. Can i upgrade to a newer iOS (doesnt have to be iOS5) and keep my unlock and jailbreak?
     
  2. HPLouis macrumors regular

    Joined:
    Nov 12, 2010
    #2
    Yes you can. You'll need to use PwnageTool or Sn0wbreeze.

    Check out www.iclarified.com for some tutorials.

    Henry
     
  3. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #3
    latest version of Redsn0w has the same features of Pwnage tools now as well. just make sure you preserve that baseband if you screw that up you are sol for a software unlock expect maybe the gevey sim.
     
  4. slipper thread starter macrumors 68000

    slipper

    Joined:
    Nov 19, 2003
    #4
    OK i'm confused now. I called a few iPhone repair/upgrade shops and they said they were not able to do it. I prefer not doing this myself because of the possibility of bricking or locking my phone. Someone mind explaining how to do this? From my understanding the latest unlockable version is 4.3.5?
     
  5. slipper thread starter macrumors 68000

    slipper

    Joined:
    Nov 19, 2003
  6. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #6
    Do you have SHSH blobs save? Open Cydia and look on top to see what you have.

    If you don't have SHSH blob save, then you can only upgrade to OS5 which it tethered jailbreak now. However, you still can use Redsn0w to create customs firmware (preserve baseband) and update your phone to it then unlocked with Ultrasn0w 1.2.4.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    5.0 would be a tethered jb.
    I'd go up to 4.3.3 if I were that is untethered. Assuming you have shsh blobs saved. Open cydia and find out what version you have available blobs for.
     

Share This Page