Question

Discussion in 'iPod touch' started by Nitromaster, Feb 14, 2008.

  1. Nitromaster macrumors 6502

    Joined:
    Jan 7, 2007
    Location:
    Ireland.
    #1
    Just ordered an ipod touch 32GB on Tuesday,its due to be delivered tomorrow :D

    Does the new ipod touch really need iTunes 7.6 or will it work with 7.5?
    Anyone tested it with lower versions?
    (I use dialup so if I need 7.6 I better start donwloading today :L )
     
  2. iloveyooh macrumors newbie

    Joined:
    Jan 10, 2008
    #2
    i would start downloading it today
    because i think you do have to have 7.6 but im not sure...
     
  3. sgtboy macrumors 6502

    Joined:
    Dec 19, 2007
  4. juanster macrumors 68020

    juanster

    Joined:
    Mar 2, 2007
    Location:
    toronto
    #4
    i think you ll only need 7.6 if you want to rent movies, i am not sure though, actually you may want to justs tart downloading anyways, just in case, because youri pod will come with the jan updates so you may need 7.6...:eek:
     
  5. Nitromaster thread starter macrumors 6502

    Joined:
    Jan 7, 2007
    Location:
    Ireland.
    #5
    I decided to chance not installing 7.6 .

    When I got my ipod touch it worked with both 7.5 on a windows pc and 7.4 on my Leopard macbook.
     

Share This Page