Questions about iMessage or text

Discussion in 'iOS 6' started by Lyons00, Aug 4, 2012.

  1. Lyons00 macrumors 6502

    Joined:
    Dec 9, 2010
    Location:
    Bay Area, California
    #1
    Hi,

    I'm on 6.0 beta 3. My question is, when sending a text to another iPhone (iMessage) it shows up on their end as my email address instead of my mobile number. This just started happening, a few days ago, but have been on 6.0 beta 3 since it came out. Is there a way to send a iMessage and a text just using my mobile number, instead of my email address?

    Thanks, Jerry
     
  2. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #2
    Check Settings -> Messages, make sure iMessage does not show Waiting for activation. Then under send/receive make sure your phone number has a check mark by it.
     
  3. Lyons00, Aug 4, 2012
    Last edited: Aug 4, 2012

    Lyons00 thread starter macrumors 6502

    Joined:
    Dec 9, 2010
    Location:
    Bay Area, California
    #3
    It does say waiting for Waiting for activation. I tried signing out of my account but that doesn't seem to be working. Now how do I get rid of Waiting for activation, so I can try your suggestion?

    Thanks, Jerry
     
  4. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    If you are on ATT doing this will cause Facetime over 3G not to work.

    The following worked for me, Settings -> General -> Reset Network settings.
     
  5. Lyons00 thread starter macrumors 6502

    Joined:
    Dec 9, 2010
    Location:
    Bay Area, California
    #5
    Thank you and yes I'm on AT&T. I will sign back with my apple id and then do what you said.

    TY
     
  6. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #6
    Hopefully it will work.
     
  7. Lyons00 thread starter macrumors 6502

    Joined:
    Dec 9, 2010
    Location:
    Bay Area, California
    #7
    Might have to wait, it showing Waiting for activation once I signed back in with my apple id. I'll let you know.

    Thanks, Jerry
     
  8. Lyons00 thread starter macrumors 6502

    Joined:
    Dec 9, 2010
    Location:
    Bay Area, California
    #8
    Thank you, that did the trick!! I didn't sign back in with my with my apple id yet. If I don't do this, your saying that, I won't be getting face-time over 3g?

    Thanks, Jerry
     
  9. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #9
    No I'm saying by doing this you lose FaceTime over 3G. AT&T pops up a message now saying call them to activate. This may change by the time it is released but for now since you did that you should not be able to use FT over 3G
     
  10. Lyons00 thread starter macrumors 6502

    Joined:
    Dec 9, 2010
    Location:
    Bay Area, California
    #10
    If I put my apple id back in, will it let me choose my mobile number or my email for iMessage? It was grayed out before, only my email was checked and couldn't check for my mobile number.

    Thanks, Jerry
     
  11. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #11
    Resetting network settings should fix both yes.
     
  12. Lyons00 thread starter macrumors 6502

    Joined:
    Dec 9, 2010
    Location:
    Bay Area, California
    #12
    I think it's right. It now says send and receive 2 addresses. One is my email and the other is my mobile number. Then it says start a new conversation from only my mobile number, I think this is what I'm looking for? (You can be reached by iMessage at mobile number and email address are both checked but grayed out).

    Thanks, Jerry
     
  13. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
  14. Lyons00 thread starter macrumors 6502

    Joined:
    Dec 9, 2010
    Location:
    Bay Area, California
    #14
    Thanks, a bit early here. Will test it later, when my son gets up. Once I hear, I'll let you know.

    Thanks again, Jerry
     
  15. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #15
    There's a section in the iMessage settings called "Caller ID". That is how you decide whether messages are sent from your # or your ID.
     
  16. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #16
    You're welcome.
     

Share This Page